2018-08-19 20:27 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003034OpenFOAM[All Projects] Bugpublic2018-08-09 06:41
ReporterSamMallinson 
Assigned Tochris 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformwindowsOSUbuntuOS Version18.04
Product Version6 
Target VersionFixed in Version 
Summary0003034: Cannot run tutorials which use #calc
DescriptionInstalled OF-6 on Windows, as per https://openfoam.org/download/windows-10/
(although I actually followed the latest instructions for setting up WSL - https://docs.microsoft.com/en-gb/windows/wsl/install-win10)

Successfully rang pitzDaily tutorial.

Tried running pipeCyclic tutorial, got the following error during blockMesh:

Creating block mesh from
    "/home/samuel/projects/test/pipeCyclic/system/blockMeshDict"
Using #calcEntry at line 26 in file "/home/samuel/projects/test/pipeCyclic/system/blockMeshDict"
Using #codeStream with "/home/samuel/projects/test/pipeCyclic/dynamicCode/platforms/linux64GccDPInt32Opt/lib/libcodeStream_9f0331af3df6a7cc6ee98d1c4223d443c63f0773.so"
Creating new library in "dynamicCode/_9f0331af3df6a7cc6ee98d1c4223d443c63f0773/platforms/linux64GccDPInt32Opt/lib/libcodeStream_9f0331af3df6a7cc6ee98d1c4223d443c63f0773.so"
Invoking "wmake -s libso /home/samuel/projects/test/pipeCyclic/dynamicCode/_9f0331af3df6a7cc6ee98d1c4223d443c63f0773"
wmake libso /home/samuel/projects/test/pipeCyclic/dynamicCode/_9f0331af3df6a7cc6ee98d1c4223d443c63f0773
/opt/openfoam6/wmake/wmake: line 410: make: command not found
/opt/openfoam6/wmake/wmake: line 413: make: command not found
wmake error: file 'Make/linux64GccDPInt32Opt/sourceFiles' could not be created in /home/samuel/projects/test/pipeCyclic/dynamicCode/_9f0331af3df6a7cc6ee98d1c4223d443c63f0773


--> FOAM FATAL IO ERROR:
Failed wmake "dynamicCode/_9f0331af3df6a7cc6ee98d1c4223d443c63f0773/platforms/linux64GccDPInt32Opt/lib/libcodeStream_9f0331af3df6a7cc6ee98d1c4223d443c63f0773.so"


file: /home/samuel/projects/test/pipeCyclic/system/blockMeshDict from line 17 to line 23.

    From function static void (* Foam::functionEntries::codeStream::getFunction(const Foam::dictionary&, const Foam::dictionary&))(Foam::Ostream&, const Foam::dictionary&)
    in file db/dictionary/functionEntries/codeStream/codeStream.C at line 218.

FOAM exiting

===

Ran other cases which use #calc and got the same error.
Steps To ReproduceInstall OF-6 on Windows.

Copy simpleFoam/pipeCyclic tutorial to working directory.

./Allrun
Additional InformationHave not encountered this error with OF-6 on other linux distros.
Tags#calc, OpenFOAM-6, Windows-10
Attached Files

-Relationships
+Relationships

-Notes

~0009922

tniemi (reporter)

The #calc functionality needs to be able to compile some code which requires a working build environment. I guess that by default, WSL does not include such packages.

From https://openfoam.org/download/source/software-for-compilation/

the following command should install all packages for the build environment:

"sudo apt-get install build-essential flex bison git-core cmake zlib1g-dev libboost-system-dev libboost-thread-dev libopenmpi-dev openmpi-bin gnuplot libreadline-dev libncurses-dev libxt-dev"

Of these at least the build-essential -package is needed for make.

~0009933

wyldckat (updater)

@Chris: I believe the minimum changes needed so far in the page https://openfoam.org/download/windows-10/ are as follows:

1. In the section "Installing OpenFOAM", update from OpenFOAM 5 to 6 or simply point to a category of Ubuntu packs?

2. Also in the section "Installing OpenFOAM", add a link to https://openfoam.org/download/source/software-for-compilation/ - as pointed out by tniemi.


Beyond this:
- I'm not sure if the section "Install Windows 10 Anniversary Update" is still needed.

- As for section "Activate Windows Subsystem for Linux", the link provided in the original report can be added as an alternative, namely https://docs.microsoft.com/en-gb/windows/wsl/install-win10

~0009937

SamMallinson (reporter)

Thanks tniemi! I can confirm that this worked for me on WSL/Ubunt1804.

Cheers,

Sam
+Notes

-Issue History
Date Modified Username Field Change
2018-08-08 04:02 SamMallinson New Issue
2018-08-08 04:02 SamMallinson Tag Attached: #calc
2018-08-08 04:02 SamMallinson Tag Attached: OpenFOAM-6
2018-08-08 04:02 SamMallinson Tag Attached: Windows-10
2018-08-08 13:04 tniemi Note Added: 0009922
2018-08-08 22:01 wyldckat Assigned To => chris
2018-08-08 22:01 wyldckat Status new => assigned
2018-08-08 22:10 wyldckat Note Added: 0009933
2018-08-09 06:41 SamMallinson Note Added: 0009937
+Issue History