View Issue Details

IDProjectCategoryView StatusLast Update
0003027OpenFOAM[All Projects] Bugpublic2018-08-08 16:19
ReporterDarko.RadenkovicAssigned Towill 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformUbuntu 16.04OSOtherOS Version(please specify)
Product Versiondev 
Fixed in Version 
Summary0003027: Particles are not introduced in turb. channel flow with cyclic boundary conditions, when simulation is run on multiple cores
DescriptionWhen solver icoUncoupledKinematicParcelFoam is used for particle tracking in turbulent channel flow, where channel flow is taken from a tutorial, case channel395, with imposed periodic boundary conditions in x and z direction, parallelization leads that particles are not introduced in domain. On single core, solver works as expected.

When further PIMPLE procedure is combined with evolving of kinematic cloud, or kinematic colliding cloud, again, parallelization leads that particles are not introduced in domain. On single core, everything works perfectly. Solver pimpleFoam in parallel mode again works normally. But above mentioned combination, does not work in parallel mode.
Steps To Reproduce1. In case channel395, particles are introduced, and for example, solver icoUncoupledKinematicParcelFoam is used. When solver is started on single core, everything is normal. When solver works on multiple cores, particles are not introduced in domain. Case is decomposed using simple method, on 6 cores.
Additional InformationProblem persists also in OpenFOAM version 1706. Case is attached, with log file as a result of work in parallel mode, and *.png figure of work on single core.
TagsNo tags attached.

Activities

Darko.Radenkovic

2018-08-03 20:48

reporter  

channel395PlusKinematicCloud.zip (1,985,960 bytes)

Darko.Radenkovic

2018-08-05 20:23

reporter   ~0009905

I discovered that this is not a bug; there should be a line in decomposeParDict:

    preservePatches (inout1_half1 inout2_half1);

(for example in above attachment) and everything works fine.

will

2018-08-08 16:19

manager   ~0009926

Yes, preserve patches is necessary in this case as without it the cyclics get converted into processor-cyclics by the decomposition. This means that the injection model now points to a patch that no longer exists, and nothing gets injected. It's not ideal, but that's how it is at the moment.

Issue History

Date Modified Username Field Change
2018-08-03 20:48 Darko.Radenkovic New Issue
2018-08-03 20:48 Darko.Radenkovic File Added: channel395PlusKinematicCloud.zip
2018-08-03 20:48 Darko.Radenkovic Tag Attached: cyclic
2018-08-05 20:23 Darko.Radenkovic Note Added: 0009905
2018-08-05 20:33 Darko.Radenkovic Tag Detached: cyclic
2018-08-08 16:19 will Assigned To => will
2018-08-08 16:19 will Status new => closed
2018-08-08 16:19 will Resolution open => no change required
2018-08-08 16:19 will Note Added: 0009926