View Issue Details

IDProjectCategoryView StatusLast Update
0003012OpenFOAMPatchpublic2018-09-18 01:15
ReporterlorenzotrevisanAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSSlackwareOS Version14.2
Product Version6 
Fixed in Version6 
Summary0003012: Allclean in new singleFluidCHT template does not get regionDirs
DescriptionAllclean in new singleFluidCHT template does not get regionDirs on Slackware 14.2 (GNU grep 2.25);

probably it is due to grep version, because if i change grep instruction at row 9 of OpenFOAM-6/etc/templates/singleFluidCHT/Allclean:

 _regionDirs="$(grep -E "^[a-Z]" constant/materialProperties | tail -n +2)"

as follows:
 _regionDirs="$(grep "^[a-zA-Z]" constant/materialProperties | tail -n +2)"

it seems to work fine on my side.

Steps To Reproduce./Allclean in a singleFluidCHT template case
Additional Informationi do not tested on other Linux
TagsNo tags attached.

Activities

henry

2018-07-24 11:56

manager   ~0009870

Resolved in OpenFOAM-dev by commit fb4cb6e57a4bd963f108678a6ba6a3bfcf49aed2
Resolved in OpenFOAM-6 by commit 63b0469a7b4f58119e367db7a1c784923a40966c

Issue History

Date Modified Username Field Change
2018-07-24 10:24 lorenzotrevisan New Issue
2018-07-24 11:56 henry Assigned To => henry
2018-07-24 11:56 henry Status new => resolved
2018-07-24 11:56 henry Resolution open => fixed
2018-07-24 11:56 henry Fixed in Version => 6
2018-07-24 11:56 henry Note Added: 0009870