View Issue Details

IDProjectCategoryView StatusLast Update
0000030OpenFOAM[All Projects] Bugpublic2010-09-13 17:37
Reporteruser36Assigned Tohenry 
PrioritylowSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000030: OF1.6.x:localBlended schemes missing correction funtions
DescriptionHello everyone,

when comparing fixedBlended.H and localBlended.H then localBlended is missing the member functions "correction" and "corrected". These should be necessary when using e.g. linearUpwind as one of the two blending schemes.
I attached a suggested fix, where I copied the two member functions with a little adjustment because the blending factor in localBlended.H is a field.

Best Regards
Dominik Christ
Steps To ReproduceTo "reproduce" compare fixedBlended.H with localBlended.H
TagsModelling, Solver

Activities

user36

2010-09-08 15:56

 

localBlended.H (6,809 bytes)

henry

2010-09-09 13:48

manager   ~0000031

localBlended: Added support for "corrected" schemes

See commit 0e234913650b9819e3d96173b027c7ddb57223ce in OpenFOAM-1.7.x git repository.

Issue History

Date Modified Username Field Change
2010-09-08 15:56 user36 New Issue
2010-09-08 15:56 user36 File Added: localBlended.H
2010-09-08 16:48 user2 Assigned To => henry
2010-09-08 16:48 user2 Status new => assigned
2010-09-09 13:48 henry Note Added: 0000031
2010-09-09 13:48 henry Status assigned => resolved
2010-09-09 13:48 henry Fixed in Version => 1.7.x
2010-09-09 13:48 henry Resolution open => fixed
2010-09-13 17:37 user2 Tag Attached: Modelling
2010-09-13 17:37 user2 Tag Attached: Solver