View Issue Details

IDProjectCategoryView StatusLast Update
0002907OpenFOAMContributionpublic2018-05-01 16:08
ReporterlorenzotrevisanAssigned Tohenry 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSSlackwareOS Version14.2
Product Version5.0 
Fixed in Versiondev 
Summary0002907: a proposal of fvOptions solidificationMeltingSource for not isotherm phase change
Descriptioncurrent fvOptions solidificationMeltingSource allows only isotherm phase change
namely for pure substance or eutectic composition mixture.
Following Voller's indication, it should be possible to take into account
the not isotherm miscible systems phase change and
the not isotherm portion of not eutectic systems phase change
introducing an at least linear relation between melt fraction alpha1 and temperature.
Focusing on cast iron portion of Fe-C phase diagram it seems to me to be fine the results obteined considering Tmelt_-> Tsol_idus-eutectic, a new Tliq_uidus > Tsol and a new alpha1e_ max eutectic melt fraction as proposed in attached files. I noted some instability on temperature results for alpha1e >= 0.9.
Steps To Reproduce1- compile fvOptions substituting attached files in fvOptions/sources/derived/solidificationMeltingSource/

2- case definition requires a new syntax for fvOptions dictionary:
   i- use Tsol instead Tmelt as previously to define melting temperature in isotherm phase change (for pure substance or eutectic mixture -> Tsol=Tliq);
   ii- optionally define new Tliq > Tsol to consider liquidus temperature in not isotherm phase change (for miscible mixture), where previous defined Tsol defines solidus temperature;
   iii- optionally define also alpha1e to consider max eutectic melt fraction (that should be the percentage of solvent phase changed from initial to eutectic liquid concentration) in partially isotherm (at Tsol=Teutectic) and not
isotherm (from Tsol=Teutectic to Tliq) phase change (for solid not miscible mixture) [alpha1e=0 -> pure substance; alpha1e=1 -> eutectic mixture that is strictely not permitted[.
Additional Informationthe attached implementation has only eutectic linear capability (lever rule) in the hope that it will be considered;
i belive a better fit to real thermal behavior should be possible introducing:
+- a negative exponent n for the factor (alpha1[celli]-alpha1e)/(1-alpha1e) for
eutectic power capability (n=1->linear, n=1/(1-k)->Sheil)
++- a control to consider a not isotherm phase change arrest at alpha1e proportional to the cooling rate (undercooling) due to solidification heat release (recalescence of irreversibility), and probably related to the exponent n too.
TagssolidificationMelting

Activities

lorenzotrevisan

2018-04-21 10:39

reporter  

solidificationMeltingSource.tar.gz (4,936 bytes)

henry

2018-05-01 16:08

manager   ~0009532

Thanks for the contribution.

Integrated by commit bad26bee71be1b56c0cc41e4bedbf491b5832567

Issue History

Date Modified Username Field Change
2018-04-21 10:39 lorenzotrevisan New Issue
2018-04-21 10:39 lorenzotrevisan File Added: solidificationMeltingSource.tar.gz
2018-04-21 10:39 lorenzotrevisan Tag Attached: solidificationMelting
2018-05-01 16:08 henry Assigned To => henry
2018-05-01 16:08 henry Status new => resolved
2018-05-01 16:08 henry Resolution open => fixed
2018-05-01 16:08 henry Fixed in Version => dev
2018-05-01 16:08 henry Note Added: 0009532