View Issue Details

IDProjectCategoryView StatusLast Update
0002898OpenFOAM[All Projects] Bugpublic2018-04-10 11:59
ReporterHmeAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSArch LinuxOS Version4.15.14-1-ARCH
Product Version5.0 
Fixed in Version 
Summary0002898: surfaceTransformPoints ignores "-case <folder>" option
DescriptionWhen running "surfaceTransformPoints" and specifying the case directory with the "-case <folder>" option, it will not find the correct file.
- "cd"-ing into the folder works
- Specifying the full path works
Steps To ReproduceCopy a .stl or .obj into any case folder
Go to parent folder, try to run with "-case <folder>" option
Watch in despair
Additional InformationMinor inconvenience when scripting OpenFOAM calls from other languages, as this option is used on other calls.
TagsNo tags attached.

Activities

Hme

2018-04-10 02:02

reporter  

hotRoom.tar.xz (44,720 bytes)

henry

2018-04-10 08:00

manager   ~0009474

The surface utilities require the path to the input and output files so they can be anywhere, either in the case directory, in any sub-directory or somewhere else so that the files can be used for multiple cases. I tested running surfaceTransformPoints in the case directory and also outside it and it runs fine, the -case option in not used or needed.

> as this option is used on other calls

Which "calls" are your referring to? Do you find that other surface manipulation utilities use the -case option in some way?

Hme

2018-04-10 10:54

reporter   ~0009476

I was not aware of that, so if this is the intended behavior, if so i apologize :)

The "case" keyword is listed under
"""
-$ surfaceTransformPoints -help
Usage: surfaceTransformPoints [OPTIONS] <surface file> <output surface file>
options:
  -case <dir> specify alternate case directory, default is the cwd
....
"""

I simply have a python script that has a general way to call OpenFOAM functions (blockMesh, snappyHexMesh, icoFoam, etc...) which uses the "-case <folder>" to select different case folders in which to do it's business.

henry

2018-04-10 10:59

manager   ~0009477

With a bit of effort we could explicitly remove the "-case" option from the list but we need funding for this kind of maintenance work:

https://openfoam.org/maintenance/
https://openfoam.org/news/funding-2018/

Hme

2018-04-10 11:07

reporter   ~0009478

That will not be necessary, simply thought it was not working as intended.
Just using it for my thesis at the moment, I will work around it :)

Found no way to close the issue, guess you are the one to do that ;)

Issue History

Date Modified Username Field Change
2018-04-10 02:02 Hme New Issue
2018-04-10 02:02 Hme File Added: hotRoom.tar.xz
2018-04-10 08:00 henry Note Added: 0009474
2018-04-10 10:54 Hme Note Added: 0009476
2018-04-10 10:59 henry Note Added: 0009477
2018-04-10 11:07 Hme Note Added: 0009478
2018-04-10 11:59 henry Assigned To => henry
2018-04-10 11:59 henry Status new => closed
2018-04-10 11:59 henry Resolution open => no change required