View Issue Details

IDProjectCategoryView StatusLast Update
0002872OpenFOAM[All Projects] Bugpublic2018-03-10 15:39
Reporterjib32Assigned Tochris 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformarm64OSFedoraOS Version27
Product Version5.0 
Fixed in Version 
Summary0002872: Paraview documentation not installed
DescriptionI followed the directions on https://openfoam.org/download/5-0-linux/ to install OpenFOAM on Fedora 27. After installation, in ParaView, going to "Help>Getting Started with ParaView" or "Example Visualizations" gives an error saying that files from opt/paraviewopenfoam54 are missing.
Steps To ReproduceFollow instructions on https://openfoam.org/download/5-0-linux/ until ParaView is launched.
On the first launch window, click on "Example Visualizations."
Additional InformationI have checked the /opt directory and there is no "paraviewopenfoam54" directory. I would try reinstalling OpenFOAM to test reproducibility but I don't know how, since the image was downloaded and installed from within the Docker environment.
A screenshot of the error is attached. The error occurs whether on the first run or on a subsequent launch of ParaView after having exited and restarted OpenFOAM.
Tagslinux, Paraview 5.4.0

Activities

jib32

2018-03-08 22:03

reporter  

error_missing_data.png (16,856 bytes)
error_missing_data.png (16,856 bytes)

chris

2018-03-09 14:37

manager   ~0009398

We don't bundle example files with ParaView. OpenFOAM has its own examples.

There must be an /opt/paraviewopenfoam54 directory inside the Docker container because the paraview executable you launched is inside:

/opt/paraviewopenfoam54/bin/paraview

jib32

2018-03-09 16:49

reporter   ~0009402

Thanks, there is a paraviewopenfoam54 directory inside the Docker container, I've never used Docker before so I assumed it would be in the system /opt directory.
Wouldn't it only be a few extra kB to include their documentation? Or at least, wouldn't it be worthwhile to remove the links and menu options that lead to documentation that is not intended to be distributed with the program?

chris

2018-03-09 19:08

manager   ~0009403

The relevant pages of the OpenFOAM User Guide provide relevant documentation for using ParaView with OpenFOAM:
https://cfd.direct/openfoam/user-guide/paraview

It would be worthwhile to remove the links and menu options but it is low priority.

wyldckat

2018-03-10 00:34

updater   ~0009404

@chris: It would be necessary to patch/hack the ParaView source code, file "Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx", method "pqParaViewMenuBuilders::buildHelpMenu", in order to omit those menu entries.


The PDF and data files needed for those menu entries are available at https://www.paraview.org/files/v5.4/ for ParaView 5.4.0 and it amounts in total to around 250-300MB in compressed format. 170MB alone is for the 'data' package.


For the upcoming ParaView 5.5 (already in RC2), at Kitware, they moved the ParaView Guide and ParaView Tutorial PDF files to download links, as visible here: https://gitlab.kitware.com/paraview/paraview/commit/1401701379b059ddc4cc5011e7384861b88e5395

However, the "getting started guide" and the data files are still needed for most of the examples in the "Example Visualizations" entry on the help menu.


It is possible to set-up an optional Deb package that downloads and unpacks these files in the right place, therefore not being a package directly provided at OpenFOAM.org... although updating the Deb package can be a bit annoying, whenever preparing a new build of ParaView.

Either way, the 'makeParaView' script stack can be updated to have the option to add these files when building it locally.
The added benefit is that users can then improve their understanding on the "several million things" that ParaView allows them to do... at least that was the original intent by the ParaView developers/contributors, hence not having an option to disable these menu entries.

chris

2018-03-10 15:39

manager   ~0009405

This is a lot of work for minimal benefit. We don't have inexhaustible resources. Most users seem to be able to use ParaView with OpenFOAM by referring to the section of the User Guide:
https://cfd.direct/openfoam/user-guide/paraview

There are numerous issues of usability that are surely higher priority than this. We can revisit this issue if a user contributes some solutions or funding for maintenance (making this issue a priority):
https://openfoam.org/maintenance/

Issue History

Date Modified Username Field Change
2018-03-08 22:03 jib32 New Issue
2018-03-08 22:03 jib32 File Added: error_missing_data.png
2018-03-08 22:03 jib32 Tag Attached: linux
2018-03-08 22:03 jib32 Tag Attached: Paraview 5.4.0
2018-03-09 14:37 chris Note Added: 0009398
2018-03-09 16:49 jib32 Note Added: 0009402
2018-03-09 19:08 chris Note Added: 0009403
2018-03-10 00:34 wyldckat Note Added: 0009404
2018-03-10 15:39 chris Note Added: 0009405
2018-03-10 15:39 chris Assigned To => chris
2018-03-10 15:39 chris Status new => closed
2018-03-10 15:39 chris Resolution open => fixed