View Issue Details

IDProjectCategoryView StatusLast Update
0002870OpenFOAMPatchpublic2018-03-07 21:37
Reporterhandrake0724Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSArchOS Version(please specify)
Product Version5.x 
Fixed in Versiondev 
Summary0002870: MVAPICH2 support
DescriptionI am using OpenFOAM with MVAPICH2. so each time new OF version is released, I have to modify bashrc, config.sh/mpi and wmake/rules directory. So, it would be nice if MVAPICH2 support is added int OF build script.

first add MVAPICH2 case in config.sh/mpi such that
MVAPICH2)
    export FOAM_MPI=mvapich2
    libDir=`mpicc -show -cc= | sed -e 's/.*-L\([^ ]*\).*/\1/'`
    export MPI_ARCH_PATH="${libDir%/*}"
    _foamAddLib $libDir
    unset libDir
    ;;

and then add mplibMVAPICH2 in wmake/rules/linux64(Icc|Gcc) which contains follwing:

  PFLAGS = -DMPICH_SKIP_MPICXX
  PINC = -isystem $(MPI_ARCH_PATH)/include
  PLIBS = -L$(MPI_ARCH_PATH)/lib -lmpi

all those changes are attached in the patch.tar.gz

TagsNo tags attached.

Activities

handrake0724

2018-03-07 13:06

reporter  

patch.tar.gz (888 bytes)

henry

2018-03-07 14:53

manager   ~0009386

> add mplibMVAPICH2 in wmake/rules/linux64(Icc|Gcc)

Why? Why not put it in wmake/rules/General? Have you created different versions for the different compilers? Is clang not supported?

handrake0724

2018-03-07 15:00

reporter   ~0009387

I didn't notice mplib* files are in wmake/rules/General because I directly examined linux64Icc and found mplibINTELMPI and mplibHPMPI.
Now that I know wmake/rules/General, it is better to put the file in the directory.

at the moment, I am not sure MVAPICH2 is supported in clang.

henry

2018-03-07 21:37

manager   ~0009389

Resolved by commit c41efee5947762c40516f46ff2d2c1ee4f79d09

Issue History

Date Modified Username Field Change
2018-03-07 13:06 handrake0724 New Issue
2018-03-07 13:06 handrake0724 File Added: patch.tar.gz
2018-03-07 14:53 henry Note Added: 0009386
2018-03-07 15:00 handrake0724 Note Added: 0009387
2018-03-07 21:37 henry Assigned To => henry
2018-03-07 21:37 henry Status new => resolved
2018-03-07 21:37 henry Resolution open => fixed
2018-03-07 21:37 henry Fixed in Version => dev
2018-03-07 21:37 henry Note Added: 0009389