View Issue Details

IDProjectCategoryView StatusLast Update
0002859OpenFOAMPatchpublic2018-02-26 14:13
ReporterhannessAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformOSUbuntu OS Version16.04
Product Version 
Fixed in Version 
Summary0002859: Calculation of average agglomerate temperature in viewFactor.C shoul incorporate power 4 weighting
DescriptionFor the calculation of the average emission per patch agglomerate the temperature is area average over the agglomerate (line 459 in viewFactor.C) in all OF versions up to 5.0. In order to give the right emission values and to conserve the enegy balance it would be bette to incorporate weighting of T^4.
Thus, line 459 should read
    Tave[coarseI] += ((pow(Tp[facei],4.0)*sf[facei])/area;
and after the loop (after line 462) the forth root should be taken:
    Tave[coarceI] = pow(Tave[coarseI],0.25);
Tagsradiation, view factor

Relationships

duplicate of 0002649 resolvedhenry View factors - area weighting for temperature 

Activities

henry

2018-02-26 13:48

manager   ~0009349

Isn't this already fixed?

hanness

2018-02-26 14:06

reporter   ~0009350

Ok, I'm sorry. I only checked up to OF5.0 and did not check the dev-version. In OpenFOAM-dev it is incorporated.

henry

2018-02-26 14:13

manager   ~0009351

This was already fixed in OpenFOAM-dev and I have made the same change co OpenFOAM-5.x.

Issue History

Date Modified Username Field Change
2018-02-26 13:16 hanness New Issue
2018-02-26 13:16 hanness Tag Attached: radiation
2018-02-26 13:16 hanness Tag Attached: view factor
2018-02-26 13:48 henry Note Added: 0009349
2018-02-26 14:06 hanness Note Added: 0009350
2018-02-26 14:07 will Relationship added duplicate of 0002649
2018-02-26 14:13 henry Assigned To => henry
2018-02-26 14:13 henry Status new => closed
2018-02-26 14:13 henry Resolution open => no change required
2018-02-26 14:13 henry Fixed in Version => 5.x
2018-02-26 14:13 henry Note Added: 0009351