View Issue Details

IDProjectCategoryView StatusLast Update
0002838OpenFOAMPatchpublic2018-02-10 17:17
Reporterhandrake0724Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx86_64OSArchOS Version
Product Version5.x 
Fixed in Version5.x 
Summary0002838: intel compiler support of makeCGAL
Descriptioncurrent makeCGAL script does not support intel compiler because toolset option of bjam is set to WM_CC while available toolset value is one of gcc, intel, clang.

So the following code could fix this problem.

        case $WM_COMPILER in
            Gcc*)
                TOOLSET=gcc
                ;;
            Icc)
                TOOLSET=intel
                ;;
            Clang)
                TOOLSET=clang
                ;;
        esac

        ./bootstrap.sh \
            --prefix=$BOOST_ARCH_PATH \
            --libdir=$boostLib \
            --with-libraries=thread \
            --with-libraries=system \
        && ./bjam toolset=$TOOLSET -j $WM_NCOMPPROCS install \
        && echo "Built: boost"
TagsNo tags attached.

Relationships

has duplicate 0002834 closedhenry ThirdParty intel compiler support of makeCGAL 

Activities

henry

2018-02-08 14:03

manager   ~0009284

Hard coding the complete list of compilers to handle the particular inconsistency with the intel naming would make it harder to support other compilers unless these are also treated inconsistently by bjam. For now I think it would be better to treat the intel iconsistency as a special case.

handrake0724

2018-02-08 14:10

reporter   ~0009285

Then, How about treating intel compiler as special case as follows:

  if [ $WM_COMPILER == "Icc" ]; then
     ./bootstrap.sh \
            --prefix=$BOOST_ARCH_PATH \
            --libdir=$boostLib \
            --with-libraries=thread \
            --with-libraries=system \
        && ./bjam toolset=intel -j $WM_NCOMPPROCS install \
        && echo "Built: boost"
  else
     ./bootstrap.sh \
            --prefix=$BOOST_ARCH_PATH \
            --libdir=$boostLib \
            --with-libraries=thread \
            --with-libraries=system \
        && ./bjam toolset=$WM_CC -j $WM_NCOMPPROCS install \
        && echo "Built: boost"
  fi

henry

2018-02-09 13:41

manager   ~0009289

Yes something like that but it could be done with less code duplication by setting a toolset variable to $WM_CC and overriding it for Intel.

henry

2018-02-09 14:03

manager   ~0009290

I am not able to reproduce this problem, for me CGAL compiles fine with the current makeCGAL and the same with toolset=intel. Could you provide more details of the issue?

henry

2018-02-09 14:18

manager   ~0009291

This is slightly simpler:

    toolset="$WM_CC"
    if [ $WM_COMPILER == "Icc" ]; then
        toolset=intel
    fi

    echo "Starting build: boost"
    (
        cd $BOOST_SOURCE_DIR || exit 1

        rm -rf $BOOST_ARCH_PATH

        ./bootstrap.sh \
            --prefix=$BOOST_ARCH_PATH \
            --with-libraries=thread \
            --with-libraries=system \
        && ./bjam toolset=$toolset -j $WM_NCOMPPROCS install \
        && echo "Built: boost"
    ) || {
        echo "Error building: boost"
        exit 1
    }

handrake0724

2018-02-10 09:51

reporter   ~0009297

With WM_CC set to icc, makeCGAL makes the following error:

Bootstrapping is done. To build, run:

    ./b2
    
To adjust configuration, edit 'project-config.jam'.
Further information:

   - Command line help:
     ./b2 --help
     
   - Getting started guide:
     http://www.boost.org/more/getting_started/unix-variants.html
     
   - Boost.Build documentation:
     http://www.boost.org/build/doc/html/index.html

icc.jam: No such file or directory

toolset list coud be found in <boost src root>/tools/build/src/tools. icc.jam is not there but intel.jam is.

I am OK with your revised script.
Thanks.

henry

2018-02-10 17:17

manager   ~0009299

Resolved in ThirdParty-5.x by commit a807587a7babd4d03b62794b26e5ef4105301416

Resolved in ThirdParty-dev by commit d99e4bf60d1fe70a7b910ab395951cb6e4f0bf43

Issue History

Date Modified Username Field Change
2018-02-08 13:13 handrake0724 New Issue
2018-02-08 14:03 henry Note Added: 0009284
2018-02-08 14:10 handrake0724 Note Added: 0009285
2018-02-08 14:41 wyldckat Relationship added has duplicate 0002834
2018-02-09 13:41 henry Note Added: 0009289
2018-02-09 14:03 henry Note Added: 0009290
2018-02-09 14:18 henry Note Added: 0009291
2018-02-10 09:51 handrake0724 Note Added: 0009297
2018-02-10 17:17 henry Assigned To => henry
2018-02-10 17:17 henry Status new => resolved
2018-02-10 17:17 henry Resolution open => fixed
2018-02-10 17:17 henry Fixed in Version => 5.x
2018-02-10 17:17 henry Note Added: 0009299