View Issue Details

IDProjectCategoryView StatusLast Update
0002822OpenFOAM[All Projects] Bugpublic2018-01-31 16:45
Reporterrolf.sieber@sms-vt.comAssigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Version5.x 
Fixed in Version5.x 
Summary0002822: Missinig time dimension in Euler Scheme for moving mesh
DescriptionPossible Error in the file EulerDdtSchme.C in function

tmp<GeometricField<Type, fvPatchField, volMesh>>
EulerDdtScheme<Type>::fvcDdt
(
    const volScalarField& alpha,
    const volScalarField& rho,
    const GeometricField<Type, fvPatchField, volMesh>& vf
)

In case of a moving mesh rDeltaT.value() is used to calculate the time derivative and not rDeltaT like in non moving mesh. This leads to the fact the the dimesion of the returned class is not correct and the program stops with the message

    [h.water[1 -1 -3 0 0 0 0] ] + [ddt(alpha.water,thermo:rho.water,K.water)[1 -1 -2 0 0 0 0] ]

during the calculation of the time derivative of the kinetic energy.
TagsNo tags attached.

Activities

henry

2018-01-31 15:20

manager   ~0009235

Steps to reproduce?

rolf.sieber@sms-vt.com

2018-01-31 15:50

reporter   ~0009236

There is no way in standard branch to reproduce the effect, since no twoPhaseEulerFoam with dynamic mesh exists.

I already implemented dynamic Mesh in twoPhaseEulerFoam in OpenFoam 4.x and got the same error. However I couldn't find the reason.

Now I try to implement dynamic Mesh in reactingTwoPhaseEulerFoam of OpenFoam 5.x and again. Since I'm more familiar with the code I guess I found the reason.

I attached the file AnisothermalPhaseModel.C, where you can find my workaround. (Marked with "RS"). Hope this helps.

AnisothermalPhaseModel.C (5,172 bytes)

henry

2018-01-31 16:45

manager   ~0009237

Resolved in OpenFOAM-5.x by commit 7bf7ed54c6ed332752b1a8647adc25c6a108f43a

Resolved in OpenFOAM-dev by commit 1a0d663977bd05fb1af23ddbd6813435bc5cb12f

Issue History

Date Modified Username Field Change
2018-01-31 15:05 rolf.sieber@sms-vt.com New Issue
2018-01-31 15:20 henry Note Added: 0009235
2018-01-31 15:50 rolf.sieber@sms-vt.com File Added: AnisothermalPhaseModel.C
2018-01-31 15:50 rolf.sieber@sms-vt.com Note Added: 0009236
2018-01-31 16:45 henry Assigned To => henry
2018-01-31 16:45 henry Status new => resolved
2018-01-31 16:45 henry Resolution open => fixed
2018-01-31 16:45 henry Fixed in Version => 5.x
2018-01-31 16:45 henry Note Added: 0009237