2018-04-20 11:30 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002801OpenFOAM[All Projects] Bugpublic2018-01-04 08:45
Reportertaherc 
Assigned Towill 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Versiondev 
Target VersionFixed in Versiondev 
Summary0002801: interfaceHeight output format
DescriptionI was trying to use interfaceHeight with one of my cases but when I checked the output file there was a problem in one of the files. I attached the output. Line 22 reads as follows:
0.00103538 5.263128e-01 5.263128e-01 -6.654478e-277-6.654478e-277

There is a space missing between the last two entries which causes problems in for example importing the file to python. I have to manually insert the space or write a bash script to deal with it. I tried setting a lower write precision but still the same problem. For some reason, maybe because it's a very small number, the writing format changes.

This is the function that I've used:
waterLevel
  {
      type interfaceHeight;
      libs ("libfieldFunctionObjects.so");
      locations
      (
        (2.66 0 0.5)
        (1 0 0.5)
      );
      alpha alpha.water;
  }
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0009195

will (manager)

Thanks for the report. You are correct in identifying that it is because the number is extremely small. Three-digit exponents aren't given the proper padding.

Resolved in dev by commit 1273b9fb.
+Notes

-Issue History
Date Modified Username Field Change
2018-01-02 04:14 taherc New Issue
2018-01-02 04:14 taherc File Added: height.dat
2018-01-04 08:44 will Assigned To => will
2018-01-04 08:44 will Status new => closed
2018-01-04 08:44 will Resolution open => fixed
2018-01-04 08:44 will Fixed in Version => dev
2018-01-04 08:44 will Note Added: 0009195
2018-01-04 08:45 will Status closed => resolved
+Issue History