View Issue Details

IDProjectCategoryView StatusLast Update
0002752OpenFOAMFeaturepublic2018-02-02 15:45
ReporterbjnieuwboerAssigned Towill 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.10
Product Version5.x 
Fixed in Version 
Summary0002752: function to determine first and last subcycle
DescriptionFor implementing own pieces of code, I often want to know if I am at the first or last subcycle in the particle tracking code. Currently, I've worked around this. However, I was wondering if it would help others if this would be implemented as two member functions of the time subcycle class.
TagsNo tags attached.

Activities

will

2017-11-07 15:28

manager   ~0009012

Why do you need to do this? The point of sub-cycling is to abstract the act of subdividing the time-step. Providing information as to the index of the current subdivision seems at odds with the intended purpose.

bjnieuwboer

2017-11-07 15:41

reporter   ~0009013

I am working in the kinematicParticle class. Here I want to compute the coefficient of restitution on the basis of incoming velocity. Therefore I need to compute this value only the first time step of the subcycling. I have a managed to do this in another way. However, for me it would have been easier to have a feature to determine the first or last subcycle. Therefore I thought others might be interested in something like this. This would enable more confinient programming on low level (say in the kinemeticParticle.). I thought this would make the life easier of other people who implement things here.

will

2017-11-09 09:06

manager   ~0009016

Every other kinematic parcel model operates within the sub-steps. I am currently of the opinion that whatever impact your coefficient of restitution is representing should involve the velocities at the start and end of the sub-step, not the outer timestep.

Why is your model different? Why does it have to be aware of the position within the sub-cycling?

will

2018-02-02 15:45

manager   ~0009242

Closing due to lack of response

Issue History

Date Modified Username Field Change
2017-11-07 13:02 bjnieuwboer New Issue
2017-11-07 15:28 will Note Added: 0009012
2017-11-07 15:41 bjnieuwboer Note Added: 0009013
2017-11-09 09:06 will Note Added: 0009016
2018-02-02 15:45 will Assigned To => will
2018-02-02 15:45 will Status new => closed
2018-02-02 15:45 will Resolution open => no change required
2018-02-02 15:45 will Note Added: 0009242