View Issue Details

IDProjectCategoryView StatusLast Update
0002750OpenFOAM[All Projects] Bugpublic2017-11-03 14:43
ReportermarlucAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version5.x 
Fixed in Version5.x 
Summary0002750: Error compiling OpenFOAM 5.x
DescriptionAfter downloading the updates for OF 5.x I cannot compile it anymore. I also tried with a clean install but with no luck.
I am using Ubuntu 14.04.
Steps To ReproduceDownload OF 5.x and install it on 14.04.
TagsNo tags attached.

Activities

marluc

2017-11-03 12:52

reporter  

log.gz (3,329 bytes)

MattijsJ

2017-11-03 14:20

reporter  

UPstream.C (22,623 bytes)

MattijsJ

2017-11-03 14:22

reporter   ~0008996

The problem is the incorrect api of those openmpi versions. Could you try the uploaded UPstream.C - it adds some explicit casting. I think I've covered all the errors.

henry

2017-11-03 14:43

manager   ~0008997

Resolved in OpenFOAM-5.x by commit 83293fa32e7fb0a8815593d894a6fd4b975cdd08

Resolved in OpenFOAM-dev by commit 1da9266df3260283573a553e31e787d642b4dd8f

Issue History

Date Modified Username Field Change
2017-11-03 12:52 marluc New Issue
2017-11-03 12:52 marluc File Added: log.gz
2017-11-03 14:20 MattijsJ File Added: UPstream.C
2017-11-03 14:22 MattijsJ Note Added: 0008996
2017-11-03 14:43 henry Assigned To => henry
2017-11-03 14:43 henry Status new => resolved
2017-11-03 14:43 henry Resolution open => fixed
2017-11-03 14:43 henry Fixed in Version => 5.x
2017-11-03 14:43 henry Note Added: 0008997