View Issue Details

IDProjectCategoryView StatusLast Update
0002746OpenFOAM[All Projects] Bugpublic2017-11-01 20:19
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Version 
Summary0002746: Clean build fails on new 'VoFphaseCompressibleTurbulenceModels' library, due to dependency on libraries from 'twoPhaseEulerFoam'
DescriptionThe library "$FOAM_SOLVERS/multiphase/compressibleInterFoam/compressibleInterPhaseTransportFoam/VoFphaseCompressibleTurbulenceModels" depends on:
 - "$FOAM_SOLVERS/multiphase/twoPhaseEulerFoam/twoPhaseSystem"
 - "$FOAM_SOLVERS/multiphase/twoPhaseEulerFoam/interfacialModels"

In a clean build, using the default build option 'stop on first error', this results in a build failure, given that the requested library possibly hasn't been built yet (which happened for me).

I haven't checked if this dependency is strictly necessary, but it does feel like it would be best to start consolidating these solver-dependent multiphase libraries into their own group folder at "$FOAM_SRC"...
TagsNo tags attached.

Activities

henry

2017-11-01 20:19

manager   ~0008977

Resolved by commit 2a1e4c42db94540f45fd084a35f92a4918e67291

Issue History

Date Modified Username Field Change
2017-11-01 20:06 wyldckat New Issue
2017-11-01 20:06 wyldckat Status new => assigned
2017-11-01 20:06 wyldckat Assigned To => henry
2017-11-01 20:19 henry Status assigned => resolved
2017-11-01 20:19 henry Resolution open => fixed
2017-11-01 20:19 henry Note Added: 0008977