View Issue Details

IDProjectCategoryView StatusLast Update
0002737OpenFOAM[All Projects] Bugpublic2017-10-24 13:27
ReportersolarCFDAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformGNU/LinuxOSSUSE Linux EnterpriseOS Version11.2
Product Version 
Fixed in Version 
Summary0002737: fixedShearStress: "Found duplicated entries with keyword value"
DescriptionWhen using the fixedShearStress boundary condition the keyword "value" and corresponding velocity vectors are written twice.
The resulting BC looks like (vectorList1 and vectorList2 are identical!):

BC_name
{
type fixedShearStress;
value nonuniform List<vector>
vectorList1
;
tau (0 0 0);
value nonuniform List<vector>
vectorList2
;
}

This hinders the U field from being loaded in paraview (decomposed mode).
Steps To ReproduceTake a case with a fixedShearStress BC, run it and try to load the decomposed case in paraview.
TagsNo tags attached.

Relationships

duplicate of 0002556 resolvedhenry Value is written twice for boundary condition fixedShearStress 

Activities

henry

2017-10-24 13:27

manager   ~0008928

commit 4371e8504d25c5c75c47bf7a072e9a3c38c6ad1f
Author: Henry Weller <http://cfd.direct>
Date: Thu May 18 19:56:16 2017 +0100

    fixedShearStressFvPatchVectorField: Removed duplicate "value" entry
    
    Resolves bug-report https://bugs.openfoam.org/view.php?id=2556

Issue History

Date Modified Username Field Change
2017-10-24 13:18 solarCFD New Issue
2017-10-24 13:27 henry Assigned To => henry
2017-10-24 13:27 henry Status new => closed
2017-10-24 13:27 henry Resolution open => duplicate
2017-10-24 13:27 henry Note Added: 0008928
2017-10-24 13:27 henry Relationship added duplicate of 0002556