View Issue Details

IDProjectCategoryView StatusLast Update
0002734OpenFOAM[All Projects] Bugpublic2017-11-02 08:29
ReporterMattSAssigned Towill 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformCray XC40OSCray Linux EnvironmentOS Version(please specify)
Product Versiondev 
Fixed in Version5.x 
Summary0002734: setWaves with compressibleMultiphaseInterFoam - waveAlpha sets air phase boundary condition wrong?
DescriptionI am currently trying to use the new wave toolbox in OpenFoam-dev with compressibleMultiphaseInterFoam. (I have previously used waves2Foam with OF2.1)

The simulation is of a simple channel flow with a water layer and an overlying air phase, essentially a numerical wave tank/flume.
I am initializing the waves by running
setWaves -alpha alpha.water
then
setWaves -alpha alpha.air (for the air I am using with the "liquid no;" option in the waveAlpha condition for theinlet boundary field) (see attached files)

This initializes the phases correctly and everything appears to be ok at time t = 0, then as soon as the simulation starts the inlet condition for alpha.air switches to the same as that for the water phase (instead of air) as the simulation goes on.
So my alpha.air and my alpha.water at the inlet have the same value at t > 0.
Everything else seems fine and the simulation is running, albeit with non-physical results due to this issue at the inlet.

Steps To Reproduce1) Set up numerical tank with compressibleMultiphaseInterFoam, heavy phase water, light phase air. (I am running LES, but I see the same behavior in laminar.)

2) setWaves -alpha alpha.water

3) setWaves -alpha alpha.air
(everything looks fine until here)

4) start simulation: now alpha.water and alpha.air at the inlet boundary have the same value
Additional InformationI am using OpenFoam-dev, but the file headers in the files below still mention OF2.4.
TagscompressibleMultiphaseInterFoam, setWaves, waveAlpha

Activities

MattS

2017-10-23 15:56

reporter  

alphaorg_files.tar (10,240 bytes)

will

2017-10-23 16:36

manager   ~0008922

The liquid flag wasn't being written out, so, the alpha.air file written out by setWaves didn't have "liquid no" in it.

Resolved in dev by commit 9cb8b71e and in 5.x by d8a1697d.

I'm pretty sure this is the issue, but if I've misdiagnosed and this doesn't fix your problem, please reopen this report and upload a complete case that reproduces the issue.

Issue History

Date Modified Username Field Change
2017-10-23 15:56 MattS New Issue
2017-10-23 15:56 MattS File Added: alphaorg_files.tar
2017-10-23 15:56 MattS Tag Attached: compressibleMultiphaseInterFoam
2017-10-23 15:56 MattS Tag Attached: setWaves
2017-10-23 15:56 MattS Tag Attached: waveAlpha
2017-10-23 16:36 will Assigned To => will
2017-10-23 16:36 will Status new => resolved
2017-10-23 16:36 will Resolution open => fixed
2017-10-23 16:36 will Fixed in Version => 5.x
2017-10-23 16:36 will Note Added: 0008922
2017-11-02 08:29 will View Status private => public