2017-12-15 18:01 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002723OpenFOAM[All Projects] Bugpublic2017-10-15 10:26
Reporterliuwenju 
Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformUnixOSOtherOS Version(please specify)
Product Version4.0 
Target VersionFixed in Version 
Summary0002723: error happens while run parallel
Descriptionmpirun has exited due to process rank 12 with PID 12508 on node c17b06 exiting without calling "finalize". This may have caused other processes in the application to be terminated by signals sent by mpirun (as reported here).
Additional InformationI'm running interFoam in cluster. This cluster's system is redhat 5.5, openmpi is 1.4.3 and gcc 4.9.3. When i use 12 cores to run interFoam parallel, it works rightly, but when the cores used are 24, it couldn't work. This cluster have 12 cores every node, so i think the parallel in different node may be wrong!
TagsdecomposePar, interFoam, parallel
Attached Files

-Relationships
+Relationships

-Notes

~0008862

liuwenju (reporter)

Oct 12 21:21:04 2017 5231 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5235 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5234 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5236 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5237 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5238 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5239 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5241 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5240 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5242 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5243 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 21:21:04 2017 5244 3 8.0 TS: execvp(interFoam) failed. No such file or directory
Oct 12 22:21:26 2017 1852 4 8.0 handleTSRegisterTerm(): TS reports task <0> pid <1875> on host<c14b02> killed or core dumped
--------------------------------------------------------------------------
mpirun has exited due to process rank 12 with PID 1863 on
node c14b02 exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
--------------------------------------------------------------------------

~0008873

liuwenju (reporter)

This question has been solved. While you run a solver parallel, you have to export your environment settings to all nodes!
+Notes

-Issue History
Date Modified Username Field Change
2017-10-12 14:26 liuwenju New Issue
2017-10-12 14:35 liuwenju Tag Attached: decomposePar
2017-10-12 14:36 liuwenju Tag Attached: interFoam
2017-10-12 14:36 liuwenju Tag Attached: parallel
2017-10-12 15:27 liuwenju Note Added: 0008862
2017-10-15 03:27 liuwenju Note Added: 0008873
2017-10-15 10:11 wyldckat Status new => closed
2017-10-15 10:11 wyldckat Resolution open => no change required
2017-10-15 10:26 henry Assigned To => henry
2017-10-15 10:26 henry Status closed => resolved
+Issue History