View Issue Details

IDProjectCategoryView StatusLast Update
0002710OpenFOAMContributionpublic2017-10-13 11:32
ReporterfanqAssigned Tohenry 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Fixed in Version5.x 
Summary0002710: blockMesh addNote part gives an diagram of clockwise coordinate system
DescriptionIn "blockMesh.C" file, there is an "argList::addNote" statement, which give a block description. With the command "blockMesh -help", a diagram is given, in which, according to the vetex order (0-1-2-3, 4-5-6-7), a clockwise coordinate system is illustrated. Maybe an anti-clockwise system is more proper?

PS: The diagram is attached.
TagsNo tags attached.

Activities

fanq

2017-10-02 09:26

reporter  

2017-10-02_162339.png (9,933 bytes)
2017-10-02_162339.png (9,933 bytes)

henry

2017-10-02 15:05

manager   ~0008811

In what way is this diagram incorrect? It looks consistent with the definition of the blocks in blockMesh and following it produces correct meshes. If you find the diagram misleading in anyway we could simply remove it.

fanq

2017-10-03 05:21

reporter   ~0008813

@henry In the diagram, it seems to we want build a block hex (0 1 2 3 4 5 6 7), and according to user guide 5.3, there is a local coordinate system (x1, x2, x3) and the x1 direction is from vertex 0 to vertex 1, which is to the right in the diagram, and x2 direction is from vertex 1 to vertex 2, which is towards us in the diagram, so x3 direction should be downward if we want a right-handed coordinate system, but in the diagram, the x3 direction (from vertex 0 to vertex 4) is upward.

PS: please correct me if I mistake some concepts.

henry

2017-10-03 08:17

manager   ~0008815

It is not clear what the problem is, can you provide a single block mesh generated following the blockMesh diagram which is incorrect?

What exactly do you want done to the diagram? Can you provide a patch which include the changes you want and a demonstration mesh which shows they are correct?

henry

2017-10-06 10:15

manager   ~0008819

Please reopen this report when you can provide an example mesh which shows that the block description is incorrect and a patch which writes the corrected diagram.

fanq

2017-10-12 11:06

reporter   ~0008860

I will try to make my question clear. With the diagram shown by blockMesh -help, I will add this to blockMeshDict:

vertices
(
    (0 0 0) // 0
    (0 1 0) // 1
    (1 1 0) // 2
    (1 0 0) // 3

    (0 0 1) // 4
    (0 1 1) // 5
    (1 1 1) // 6
    (1 0 1) // 7
);

blocks
(
    hex (0 1 2 3 4 5 6 7) (20 20 20) simpleGrading (1 1 1)
);

which does not work with blockMesh in OpenFOAM 5.0.
I guess the diagram tries to tell us to add this to blockMeshDict:

vertices
(
    (0 0 0) // 0
    (1 0 0) // 1
    (1 1 0) // 2
    (0 1 0) // 3

    (0 0 1) // 4
    (1 0 1) // 5
    (1 1 1) // 6
    (0 1 1) // 7
);

blocks
(
    hex (0 1 2 3 4 5 6 7) (20 20 20) simpleGrading (1 1 1)
);

which coresponses to a diagram like this (in my opinion):

           4 ---- 7
      f3 |\ |\ f5
      | | 5 ---- 6 \
      | 0 |--- 3 | \
      | \| \| f4
      f2 1 ---- 2

          f0 ----- f1

(please note the positions of vertex 1, 3, 5, 7)
and in blockMesh -help, the diagram is:


           4 ---- 5
      f3 |\ |\ f5
      | | 7 ---- 6 \
      | 0 |--- 1 | \
      | \| \| f4
      f2 3 ---- 2

          f0 ----- f1


 

fanq

2017-10-12 11:11

reporter  

blockMesh.png (1,719 bytes)
blockMesh.png (1,719 bytes)

fanq

2017-10-12 11:12

reporter  

prefered.png (1,757 bytes)
prefered.png (1,757 bytes)

fanq

2017-10-12 11:14

reporter   ~0008861

Sorry for the ugly looks of the diagrams. I submit two pitures of the diagrams: prefered.png corresponds the one I think it should be, and blockMesh.png corresponds to blockMesh -help

henry

2017-10-13 11:32

manager   ~0008866

Resolved in OpenFOAM-5.x by commit 2d5af005e56a76eb2f7b6ad1b5bd2a12035705fc

Resolved in OpenFOAM-dev by commit 8f5a3875f6e6e693227d613506a08ae2b2fb51c3

Issue History

Date Modified Username Field Change
2017-10-02 09:26 fanq New Issue
2017-10-02 09:26 fanq File Added: 2017-10-02_162339.png
2017-10-02 15:05 henry Note Added: 0008811
2017-10-03 05:21 fanq Note Added: 0008813
2017-10-03 08:17 henry Note Added: 0008815
2017-10-06 10:15 henry Assigned To => henry
2017-10-06 10:15 henry Status new => closed
2017-10-06 10:15 henry Resolution open => unable to reproduce
2017-10-06 10:15 henry Note Added: 0008819
2017-10-12 11:06 fanq Status closed => feedback
2017-10-12 11:06 fanq Resolution unable to reproduce => reopened
2017-10-12 11:06 fanq Note Added: 0008860
2017-10-12 11:11 fanq File Added: blockMesh.png
2017-10-12 11:12 fanq File Added: prefered.png
2017-10-12 11:14 fanq Note Added: 0008861
2017-10-12 11:14 fanq Status feedback => assigned
2017-10-13 11:32 henry Status assigned => resolved
2017-10-13 11:32 henry Resolution reopened => fixed
2017-10-13 11:32 henry Fixed in Version => 5.x
2017-10-13 11:32 henry Note Added: 0008866