2018-03-21 03:12 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002648OpenFOAM[All Projects] Bugpublic2017-08-04 11:50
Assigned Tohenry 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Target VersionFixed in Version5.x 
Summary0002648: makeCMake has a hard coded version of cmake which is to old for building paraview
DescriptionThe version of the cmake package which is hard coded in makeCmake is 3.2.1. Paraview needs at least 3.3:

Make Error at CMakeLists.txt:31 (cmake_minimum_required):
  CMake 3.3 or higher is required. You are running version 3.2.1
Steps To Reproducegit clone git://github.com/OpenFOAM/ThirdParty-dev.git
source /opt/pkg/simulation/OpenFOAM/fwd/OpenFOAM-dev/etc/bashrc FOAMY_HEX_MESH=yes
mkdir download
wget -P download http://www.cmake.org/files/v3.2/cmake-3.2.1.tar.gz
./makeCmake > log.makeCM 2>&1
./makeParaView -python -mpi -python-lib $PYTHONLIBSTATIC/libpython2.7.so.1.0
Additional InformationSolution: sed -i -e 's/\(cmakePACKAGE=\)cmake-3.2.1/\1cmake-3.9.0/' $WM_THIRD_PARTY_DIR/makeCmake
TagsNo tags attached.
Attached Files




fs1982 (reporter)

Another change is required to build paraview:
sed -i -e 's/\(for cmake in \)cmake-3.2.1/\1cmake-3.9.0 cmake-3.2.1/' $WM_PROJECT_DIR/etc/config.sh/paraview


henry (manager)

Resolved in OpenFOAM-dev and OpenFOAM-5.x

-Issue History
Date Modified Username Field Change
2017-08-04 08:19 fs1982 New Issue
2017-08-04 09:21 fs1982 Note Added: 0008507
2017-08-04 11:50 henry Assigned To => henry
2017-08-04 11:50 henry Status new => resolved
2017-08-04 11:50 henry Resolution open => fixed
2017-08-04 11:50 henry Fixed in Version => 5.x
2017-08-04 11:50 henry Note Added: 0008510
+Issue History