View Issue Details

IDProjectCategoryView StatusLast Update
0002647OpenFOAM[All Projects] Bugpublic2018-07-10 11:25
ReporterArneAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Version 
Summary0002647: frictional stress in kinetic theory modeling not taken into account
DescriptionBased on my understanding of the thesis of Berend van Wachem the frictional stress has to be taken into account for computing granular temperature equation. In twoPhaseEulerFoam only the granular part is taken into account.

To be more specific the file in question is:

$FOAM_SOLVERS/multiphase/twoPhaseEulerFoam/phaseCompressibleTurbulenceModels/kineticTheoryModels/kineticTheoryModel.C

In line 388: the solid shear viscosity is computed based the table in van Wachems thesis (p.47 table 3.2). After that the viscosity is used to compute the solid stress tensor. However, in the thesis is stated (p.52 equation 3.27 and 3.28) that if the solid volume fraction is higher than a threshold value the frictional values have to be added. To my understanding this doesn't happen in the current implementation of the granular temperature equation.

The same issue occurs for the solid phase pressure later on in the same function. The pressure is computed due to p.45 eq. 3.22. However, the frictional pressure (p. 52 eq. 3.28) is not taken into account.

The frictional terms seem to be ignored intentionally which makes doubt whether I missed something or this part of the implementation is based on more recent publication. Nevertheless, I attached a kineticTheoryModel.C file which includes an in my opinion correct implementation. I ran the fluidized bed test case (RAS and kinetic Theory activated, equilibrium deactivated) with it and encountered no problems.

(van Wachem thesis : https://repository.tudelft.nl/islandora/object/uuid:919e2efa-5db2-40e6-9082-83b1416709a6/?collection=research )
Tagsmultiphase

Relationships

related to 0001831 closedhenry Errors in application of twoPhaseEulerFoam frictional stress 

Activities

Arne

2017-08-03 10:43

reporter  

kineticTheoryModel.C (15,024 bytes)

tniemi

2017-08-03 11:34

reporter   ~0008502

Hi

This issue was discussed a couple of years ago, see https://bugs.openfoam.org/view.php?id=1831.

Arne

2017-08-03 12:48

reporter   ~0008503

Hi tniemi,

thanks for your help. In this case the issue is resolved. Although I understand literature different. However, this has been discussed already.

henry

2017-08-04 11:14

manager   ~0008509

See https://bugs.openfoam.org/view.php?id=1831

Issue History

Date Modified Username Field Change
2017-08-03 10:43 Arne New Issue
2017-08-03 10:43 Arne File Added: kineticTheoryModel.C
2017-08-03 10:43 Arne Tag Attached: multiphase
2017-08-03 10:43 Arne Tag Attached: kineticTheory
2017-08-03 11:34 tniemi Note Added: 0008502
2017-08-03 12:48 Arne Note Added: 0008503
2017-08-04 11:14 henry Assigned To => henry
2017-08-04 11:14 henry Status new => closed
2017-08-04 11:14 henry Resolution open => no change required
2017-08-04 11:14 henry Note Added: 0008509
2017-08-04 11:14 henry Relationship added related to 0001831
2018-07-10 11:25 administrator Tag Detached: kineticTheory