View Issue Details

IDProjectCategoryView StatusLast Update
0002646OpenFOAM[All Projects] Bugpublic2017-08-07 10:00
ReporterSamMallinsonAssigned Tohenry 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSMintOS VersionBetsy
Product Version5.0 
Fixed in Version5.0 
Summary0002646: Cannot launch openfoam5-linux / docker
DescriptionI followed the instructions for installing OpenFOAM-5.0 using docker, as per:

https://openfoam.org/download/5-0-linux/

All went well upto Step 5: Launching openfoam5-linux

I created the directory $(HOME)/OpenFOAM/samuel-5.0, cd'd to it and then issued the command openfoam5-linux

I got the following error:

~/OpenFOAM/samuel-5.0 $ openfoam5-linux
Launching /usr/bin/openfoam5-linux
User: "samuel" (ID 1026, group ID 2001)
/bin/sh: 1: /entry.sh: Permission denied
Steps To ReproduceFollow installation instructions, issue command "openfoam5-linux"
Additional Informationcheck on OS:

~/OpenFOAM/samuel-5.0 $ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: LMDE 2 Betsy
Release: 2
Codename: betsy

NB: tried logging out / in a number of times, got the same result
TagsInstallation

Activities

chris

2017-08-03 08:42

manager   ~0008499

Thanks for reporting. Apologies, there was a permissions problem on entry.sh. Rebuilding Docker images now... should be ready in 1 hr or so

chris

2017-08-03 09:25

manager   ~0008500

Rebuilt Docker image. Please test and confirm OK

SamMallinson

2017-08-06 23:11

reporter   ~0008524

I deleted the old docker image and downloaded it again (STep 4), but when I tried to launch, I got the same error.

wyldckat

2017-08-06 23:59

updater   ~0008525

I've tested just now the installation steps from step #4 and onwards at https://openfoam.org/download/5-0-linux/ - on my machine at home that has Ubuntu 16.04 and in which I already had Docker ready to be used. I hadn't gotten this image yet before (for OpenFOAM 5.0) and it worked fine for me just now.

@SamMallinson: What commands did you use to delete the old docker image?
Because it looks like that perhaps the image wasn't fully deleted?

When I run the following command:

   docker image ls

I get the following details:

  REPOSITORY TAG IMAGE ID CREATED SIZE
  openfoam/openfoam5-paraview54 latest 1e5f2578a86a 3 days ago 2.13GB

Please compare to the "IMAGE ID" that you get.


In addition, check if there isn't a container still using the old image, by running:

  docker container ls

SamMallinson

2017-08-07 00:05

reporter   ~0008526

~/OpenFOAM/samuel-5.0 $ docker image ls
REPOSITORY TAG IMAGE ID CREATED SIZE
openfoam/openfoam5-paraview54 latest a12cf2e39056 11 days ago 2.12GB
ubuntu latest 14f60031763d 2 weeks ago 120MB
hello-world latest 1815c82652c0 7 weeks ago 1.84kB

so it looks like I didn't delete it properly - what would be the command to delete it properly?

docker container ls came back empty

SamMallinson

2017-08-07 00:09

reporter   ~0008527

OK, figured out I need to:
>$ docker images -a

then

>$ docker rmi a12cf2e39056 # using the image number from previous comment

SamMallinson

2017-08-07 00:44

reporter   ~0008528

ran test case pitzDaily OK via docker

this issue can be closed

SamMallinson

2017-08-07 00:44

reporter   ~0008529

Thanks Chris and Bruno!!

Issue History

Date Modified Username Field Change
2017-08-03 05:55 SamMallinson New Issue
2017-08-03 05:55 SamMallinson Tag Attached: Installation
2017-08-03 08:42 chris Note Added: 0008499
2017-08-03 09:25 chris Note Added: 0008500
2017-08-06 23:11 SamMallinson Note Added: 0008524
2017-08-06 23:59 wyldckat Note Added: 0008525
2017-08-07 00:05 SamMallinson Note Added: 0008526
2017-08-07 00:09 SamMallinson Note Added: 0008527
2017-08-07 00:44 SamMallinson Note Added: 0008528
2017-08-07 00:44 SamMallinson Note Added: 0008529
2017-08-07 10:00 henry Assigned To => henry
2017-08-07 10:00 henry Status new => resolved
2017-08-07 10:00 henry Resolution open => fixed
2017-08-07 10:00 henry Fixed in Version => 5.0