View Issue Details

IDProjectCategoryView StatusLast Update
0002605OpenFOAM[All Projects] Bugpublic2017-07-10 18:04
ReporterandreAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuSEOS VersionLeap 42.1
Product Versiondev 
Fixed in Version 
Summary0002605: tutorial hotBoxes: different results from OF-2.3.x to OF-dev
DescriptionDear OpenFOAM-Team,

running ./Allrun-parallel in tutorial "hotBoxes" of OF-2.3.x seems to give physically reasonable results, liquid film temperatures up to 349 K and retrained droplets have higher temperatures than 300 K. In OF-dev the liquid film and the droplets remain cold. Heat transfer from the hotBoxes to the liquid film do not occure. Maximum liquid film temperatures around 301 K. See attached figures.

the same issue was reported earlier for OF2.1.x -> OF2.3.x (see ID 0001207) and was resolved doing "thermoSingleLayer: Revert q back to the working version in OpenFOAM-2.1.x"

Best regards
Steps To Reproduceexecute ./Allrun-parallel in hotBoxes-tutorial of OF-2.3.x and OF-dev
TagsNo tags attached.

Relationships

related to 0002179 closedhenry Problems with running the tutorial cases in "lagrangian/reactingParcelFilmFoam" 

Activities

andre

2017-07-06 15:49

reporter  

hotBoxesFigures.zip (95,925 bytes)

henry

2017-07-06 15:57

manager   ~0008355

How recent is the OpenFOAM-dev you are using?

andre

2017-07-06 16:55

reporter   ~0008356

Hello Henry

last git pull on 28.06.2017 14:40

wyldckat

2017-07-06 18:07

updater   ~0008357

I've added a relationship to the report I did last year (#2179) on a related topic, although at the time it referred to OpenFOAM 4.x.

A summary of that report: the modelling was improved on the film heat-transfer implementation for OpenFOAM 4.x/dev, but unfortunately the affected tutorials were not updated to give similar results to the ones in 3.0.x and older.

Since that report, I haven't managed to understand how this tutorial case (and sibling cases) can be adapted to have similar set-ups to give similar results to the past versions.


@andre: For what time snapshot are those figures that you attached?

andre

2017-07-07 08:22

reporter   ~0008361

Hello wyldckat

snapshots were taken at t=1.2 s

henry

2017-07-10 08:29

manager   ~0008372

I have found the problem, it is in the handling of the "alpha" field which is the indicator for the presence of the film which I use to filter the heat transfer to avoid instability when the film is VERY thin. The problem is that "alpha" is also adjusted for hydrophilic and hydrophobic surfaces so includes other physics:

        forAll(alpha_, i)
        {
            if ((alpha_[i] < 0.5) && (delta_[i] > hydrophilicWet))
            {
                alpha_[i] = 1.0;
            }
            else if ((alpha_[i] > 0.5) && (delta_[i] < hydrophilicDry))
            {
                alpha_[i] = 0.0;
            }
        }

which should probably be in a separtate field.

I have constructed an "alpha" without the hydrophilic/phobic switching for the c0heat transfer filtering and pushed the change:

commit 784d28d4404856ff744991d92b25e0a6b43d15c9

If it works OK for a range of cases I will make the same change to 4.x and 3.0.x.

henry

2017-07-10 18:04

manager   ~0008378

Resolved in OpenFOAM-4.x by c989277b5e4895c60f985bb4dfd412ea8aa9916b

Resolved in OpenFOAM-dev by 784d28d4404856ff744991d92b25e0a6b43d15c9

Issue History

Date Modified Username Field Change
2017-07-06 15:49 andre New Issue
2017-07-06 15:49 andre File Added: hotBoxesFigures.zip
2017-07-06 15:57 henry Note Added: 0008355
2017-07-06 16:55 andre Note Added: 0008356
2017-07-06 17:58 wyldckat Relationship added related to 0002179
2017-07-06 18:07 wyldckat Note Added: 0008357
2017-07-07 08:22 andre Note Added: 0008361
2017-07-10 08:29 henry Note Added: 0008372
2017-07-10 18:04 henry Assigned To => henry
2017-07-10 18:04 henry Status new => resolved
2017-07-10 18:04 henry Resolution open => fixed
2017-07-10 18:04 henry Fixed in Version => 4.x
2017-07-10 18:04 henry Note Added: 0008378