View Issue Details

IDProjectCategoryView StatusLast Update
0002550OpenFOAMFeaturepublic2018-10-08 11:32
ReportercyzhangAssigned Tohenry 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version 
Fixed in Version 
Summary0002550: error when running movingConeTopoFvMesh in parallel
DescriptionI'm modeling a rigid body moving through a tube. I slightly modified "movingConeTopoFvMesh" unit to add and remove layers.

The code works well when using single processor. However, if running with multi-processors, I met the following error:

[2] --> FOAM FATAL ERROR:
[2] in patch:procBoundary2to1 : Local size of patch is 51 (faces).
Received from neighbour 23 faceCentres!
[2]
[2] From function virtual bool Foam::processorPolyPatch::order(Foam::PstreamBuffers&, const primitivePatch&, Foam::labelList&, Foam::labelList&) const
[2] in file meshes/polyMesh/polyPatches/constraint/processor/processorPolyPatch.C at line 922.
[2]
FOAM parallel run aborting

Anyone knows how to solve this issue? Thank you so much.
Tagsparallel, topoChangerFvMesh

Activities

Shorty

2018-10-05 06:26

reporter   ~0010082

Hi @cyzhang,

does this error appear right at the beginning? A test case including your development is recommended to investigate your problem.
Generally, it has to work (I did some tests at the beginning of this year).

Issue History

Date Modified Username Field Change
2017-05-15 20:50 cyzhang New Issue
2017-05-15 20:50 cyzhang Tag Attached: parallel
2017-05-15 20:50 cyzhang Tag Attached: topoChangerFvMesh
2017-05-15 20:50 cyzhang Tag Attached: topological change
2018-07-10 11:23 administrator Tag Detached: topological change
2018-10-05 06:26 Shorty Note Added: 0010082
2018-10-08 11:32 henry Assigned To => henry
2018-10-08 11:32 henry Status new => closed
2018-10-08 11:32 henry Resolution open => unable to reproduce