View Issue Details

IDProjectCategoryView StatusLast Update
0002535OpenFOAMFeaturepublic2017-05-01 22:10
Reportermichele666Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version16.04.2
Product Version 
Fixed in Version 
Summary0002535: postProcess utility doesn't work for multiregion cases
DescriptionFollowing steps at chapters 6.2.2, 6.2.3, 6.2.4, 6.3.1, for postProcessing or sampling data, during solver execution (e.g. chtMutiRegionSimpleFoam) gives this warning, tested on multiRegionHeaterRadiation tutorial:

--> FOAM Warning :
    From function bool Foam::functionObjectList::read()
    in file db/functionObjects/functionObjectList/functionObjectList.C at line 671
    Caught FatalError
--> FOAM FATAL ERROR:

    request for objectRegistry region0 from objectRegistry multiRegionHeaterRadiation failed
    available objects of type objectRegistry are

5
(
bottomAir
rightSolid
heater
topAir
leftSolid
)
Steps To Reproduceat multiRegionHeaterRadiation folder tutorial:
>> cp $FOAM_ETC/caseDicts/postProcessing/flowRate/flowRatePatch system
edit control Dict by adding
functions
{
    #includeFunc flowRatePatch
}
edit flowRatePatch and typing maxX as patchName
run ./Allrun

Additional Informationno folder postProcessing created

TagschtMultiregionFoam, Post-processing

Relationships

related to 0002534 new singleGraph does not function in "chtMultiRegionFoam -postProcess" 

Activities

wyldckat

2017-05-01 20:14

updater   ~0008055

Note: when editing "system/flowRatePatch", also add the region, e.g.:

   region bottomAir;

Nonetheless, this does not solve the problem right now, but does help isolate the issue and how to fix it, i.e. possibly load only the relevant regions and other regions are loaded only if explicitly requested?

wyldckat

2017-05-01 22:09

updater   ~0008057

Regarding the original report, a workaround to this issue has been documented at the following forum post: https://www.cfd-online.com/Forums/openfoam-post-processing/187129-postprocess-run-time-data-processing-multiregion-case.html#post647272 - because this was originally asked there.

The workaround is to use "chtMutiRegionSimpleFoam -postProcess" and properly configure the "functions" entry, e.g.:

    functions
    {
        flowRatePatch
        {
          name maxX;
          region topAir;

          #includeEtc "caseDicts/postProcessing/flowRate/flowRatePatch.cfg"
        }
    }

-------------------------

Now, going back to the issue with the "postProcess" utility..... wait, this is already solved, at least since OpenFOAM 4.1. If I use the following command:

  postProcess -func flowRatePatch(name=maxX) -region topAir

as listed in the first post on the forum thread, it works just fine in OpenFOAM 4.1 and 4.x, but fails in OpenFOAM 4.0.

This was already fixed in commit 168b29e2cfc8062867ed30928d824188e0858630: https://github.com/OpenFOAM/OpenFOAM-4.x/commit/168b29e2cfc8062867ed30928d824188e0858630


This reported issue was due to the original reported using the port of OpenFOAM 4.x in blueCFD-Core 2016-1 that is missing this feature.


I'm closing this issue as already fixed in OpenFOAM 4.x.

wyldckat

2017-05-01 22:10

updater   ~0008058

Assigned it to Henry, since he was the one that originally fixed this issue.

Issue History

Date Modified Username Field Change
2017-05-01 18:58 michele666 New Issue
2017-05-01 18:58 michele666 Tag Attached: chtMultiregionFoam
2017-05-01 18:58 michele666 Tag Attached: Post-processing
2017-05-01 19:53 wyldckat Relationship added related to 0002534
2017-05-01 20:14 wyldckat Note Added: 0008055
2017-05-01 21:16 wyldckat Severity major => minor
2017-05-01 21:16 wyldckat Category Bug => Feature
2017-05-01 22:09 wyldckat Note Added: 0008057
2017-05-01 22:10 wyldckat Assigned To => henry
2017-05-01 22:10 wyldckat Status new => resolved
2017-05-01 22:10 wyldckat Resolution open => fixed
2017-05-01 22:10 wyldckat Fixed in Version => 4.x
2017-05-01 22:10 wyldckat Note Added: 0008058