View Issue Details

IDProjectCategoryView StatusLast Update
0002529OpenFOAM[All Projects] Bugpublic2018-07-10 11:24
Reporterhk318iAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Versiondev 
Summary0002529: triSurfaceMesh in blockMesh
DescriptionHello,

I noticed that triSurfaceMesh is selectable in the new blockMesh extension (projection) in OpenFOAM-dev, So I tried to test it. triSurfaceMesh is looking for the stl file in constant/geometry instead of constant/triSurface which isn't typical in OpenFOAM. I'm not sure if this behaviour is intended or not.
Steps To Reproduce1) Use blockMesh/pipe tutorial
2) Modify geometry.cylinder dict to
    cylinder
    {
        //type searchableCylinder;
        //point1 (0 -4 0);
        //point2 (0 4 0);
        //radius 0.7;
        type triSurfaceMesh;
        file "cylinder.stl";
    }
3) Add constant/triSurface/cylinder.stl file.
Additional InformationThe problem is this function;
Foam::fileName Foam::triSurfaceMesh::checkFile
(
    const IOobject& io,
    const dictionary& dict
)
In particular, fName = io.objectPath().path()/fName;
The "io.objectPath().path()" is pointing to /geometry not /triSurface.

If this behaviour is intended, it worth to be mentioned in the class description at least.

Best wishes,
Hassan
TagsblockMesh

Activities

henry

2017-04-20 10:58

manager   ~0008034

The issue is that blockMesh can work with any form of searchableSurfaces, not just triSurfaceMesh and the location is specified as /geometry irrespective of the form of searchableSurface is provided. If the directory name were changed to /triSurface it would be odd for the other current and future forms of searchableSurface supported. The anomaly is that /triSurface is used elsewhere in OpenFOAM for reading searchableSurfaces even though they might not be triSurfaces but some other form of searchableSurface. If we were to make any change for consistency it would have to be /triSurface -> /geometry rather than the other way round.

hk318i

2017-04-20 11:13

reporter   ~0008036

I totally agree,/geometry is the general consistent way to procedure. But for now, keeping searchableExtrudedCircle reads from /triSurface is confusing. Additionally, I think searchableExtrudedCircle should be moved src/meshTools/searchableSurface.

henry

2017-04-20 11:21

manager   ~0008037

Agreed, I will make the changes to searchableExtrudedCircle you suggest.

henry

2017-04-20 12:00

manager   ~0008038

searchableExtrudedCircle cannot be put in src/meshTools/searchableSurface because it depends on edgeMesh which depends on meshTools. I can put it in edgeMesh but this is not very logical.

hk318i

2017-04-20 12:34

reporter   ~0008039

I can see the problem now, it means the only way would be moving searchableSurface + searchableExtrudedCircle to another point after edgeMesh. Maybe to src/mesh but I'm not sure if that is logical or not. what do you think?

henry

2017-04-20 12:39

manager   ~0008040

searchableExtrudedCircle can either be in the edgeMesh library or another compiled after the edgeMesh library or in a new library. src/mesh is not a library, it contains the directory for the blockMesh extrudeModel snappyHexMesh libraries but could hold yet another library for the searchableSurfaces.

hk318i

2017-04-20 12:44

reporter   ~0008041

Yes, that what I mean searchableSurfaces as library but not directly in src because it belongs to mesh in some sense but does not belongs too much to edgeMesh.
Regarding your latest commit, blockMesh/pipe/ tutorial will require small modification (moving triSurface -> geometry ).

henry

2017-04-20 12:50

manager   ~0008042

I am not keen on creating yet another mesh library, I think it would be better to merge edgeMesh into meshTools and rename meshTools to something more logical.

hk318i

2017-04-20 14:25

reporter   ~0008043

I think, that will be very sensible as well

henry

2017-04-21 10:40

manager   ~0008044

Resolved by commits:

commit 37cd5434a62e22f32c094ba18d94a45c58444a71
commit 0a32d8a11e1b8039c6637f67ada220e3a7979f0a
commit f9db06441a67912696fe2f1db2e752385340d669

Issue History

Date Modified Username Field Change
2017-04-20 10:44 hk318i New Issue
2017-04-20 10:44 hk318i Tag Attached: blockMesh
2017-04-20 10:44 hk318i Tag Attached: openfoam-dev
2017-04-20 10:58 henry Note Added: 0008034
2017-04-20 11:13 hk318i Note Added: 0008036
2017-04-20 11:21 henry Note Added: 0008037
2017-04-20 12:00 henry Note Added: 0008038
2017-04-20 12:34 hk318i Note Added: 0008039
2017-04-20 12:39 henry Note Added: 0008040
2017-04-20 12:44 hk318i Note Added: 0008041
2017-04-20 12:50 henry Note Added: 0008042
2017-04-20 14:25 hk318i Note Added: 0008043
2017-04-21 10:40 henry Assigned To => henry
2017-04-21 10:40 henry Status new => resolved
2017-04-21 10:40 henry Resolution open => fixed
2017-04-21 10:40 henry Fixed in Version => dev
2017-04-21 10:40 henry Note Added: 0008044
2018-07-10 11:24 administrator Tag Detached: openfoam-dev