View Issue Details

IDProjectCategoryView StatusLast Update
0002509OpenFOAMPatchpublic2017-03-22 19:44
ReporterChGAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Fixed in Versiondev 
Summary0002509: WallShearStress Dict - Wrong Units
DescriptionThe units written in the wallShearStress Dict are the ones for an incompressible case. Independent of the compressible or incompressible calculation. The calculations themselves are correct. Bug Fix is provided (Line 112 in file).
Steps To Reproduceset up case for rhoSimpleFoam -> perform calculation -> run "rhoSimpleFoam -postProcess -func wallShearStress"

set up case for simpleFoam -> perform calculation -> run "simpleFoam -postProcess -func wallShearStress"

check units of wallShearStress -> m^2/s^2 in both cases
TagsNo tags attached.

Activities

ChG

2017-03-21 09:27

reporter  

wallShearStress.C (7,308 bytes)

henry

2017-03-22 18:45

manager   ~0007969

> Bug Fix is provided (Line 112 in file).

Does this change compile for you? Which version of OpenFOAM are you running?

henry

2017-03-22 18:54

manager   ~0007970

I just tested in OpenFOAM-dev

rhoSimpleFoam -postProcess -func wallShearStress

on the rhoSimpleFoam/squareBend tutorial and the wallShearStress field has the dimensions [1 -1 -2 0 0 0 0].

I am unable to compile your patch and it appears to be unnecessary.

ChG

2017-03-22 19:21

reporter   ~0007971

If I run the rhoSimpleFoam/squareBend tutorial in OpeNFOAM-4.x the wallShearStress field has the dimensions [0 2 -2 0 0 0 0]. Looks like the bug already got fixed.

The fix in OpenFOAM-dev is in Line 66 of the wallShearStress.C

henry

2017-03-22 19:43

manager   ~0007972

I could not get your patch to compile in OpenFOAM-4.x either.

Issue History

Date Modified Username Field Change
2017-03-21 09:27 ChG New Issue
2017-03-21 09:27 ChG File Added: wallShearStress.C
2017-03-22 18:45 henry Note Added: 0007969
2017-03-22 18:54 henry Note Added: 0007970
2017-03-22 19:21 ChG Note Added: 0007971
2017-03-22 19:43 henry Note Added: 0007972
2017-03-22 19:44 henry Assigned To => henry
2017-03-22 19:44 henry Status new => closed
2017-03-22 19:44 henry Resolution open => fixed
2017-03-22 19:44 henry Fixed in Version => dev