View Issue Details

IDProjectCategoryView StatusLast Update
0002485OpenFOAM[All Projects] Bugpublic2017-03-05 14:53
Reporterpopstar0426Assigned Towyldckat 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformOpenFOAM 3.0.XOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0002485: Error in the compilation of metis 5.1.0
DescriptionDear all:
  I succeeded to compile metis 5.1.0 on OpenFOAM -2.4.x version.
  However, when I used the same method to complie it on OpenFOAM 3.0.x.
  There was an error:
  + cd metisDecomp
+ ./Allwmake libso
using METIS_ARCH_PATH=/home/happy/OpenFOAM/ThirdParty-3.0.x/platforms/linux64Gcc/metis-5.1.0
/home/happy/OpenFOAM/OpenFOAM-3.0.x/src/parallel/decompose/metisDecomp
Making dependency list for source file metisDecomp.C
g++ -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=64 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3 -DNoRepository -ftemplate-depth-100 -I/home/happy/OpenFOAM/ThirdParty-3.0.x/platforms/linux64Gcc/metis-5.1.0/include -I../decompositionMethods/lnInclude -IlnInclude -I. -I/home/happy/OpenFOAM/OpenFOAM-3.0.x/src/OpenFOAM/lnInclude -I/home/happy/OpenFOAM/OpenFOAM-3.0.x/src/OSspecific/POSIX/lnInclude -fPIC -c metisDecomp.C -o /home/happy/OpenFOAM/OpenFOAM-3.0.x/platforms/linux64GccDPInt64Opt/src/parallel/decompose/metisDecomp/metisDecomp.o
metisDecomp.C: In member function ‘Foam::label Foam::metisDecomp::decompose(const Foam::List<long int>&, const Foam::List<long int>&, const scalarField&, Foam::List<long int>&)’:
metisDecomp.C:66:44: error: cannot convert ‘Foam::UList<long int>::iterator {aka long int*}’ to ‘idx_t* {aka int*}’ for argument ‘1’ to ‘int METIS_SetDefaultOptions(idx_t*)’
     METIS_SetDefaultOptions(options.begin());
                                            ^
metisDecomp.C:211:9: error: cannot convert ‘Foam::label* {aka long int*}’ to ‘idx_t* {aka int*}’ for argument ‘1’ to ‘int METIS_PartGraphRecursive(idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, real_t*, real_t*, idx_t*, idx_t*, idx_t*)’
         );
         ^
metisDecomp.C:230:9: error: cannot convert ‘Foam::label* {aka long int*}’ to ‘idx_t* {aka int*}’ for argument ‘1’ to ‘int METIS_PartGraphKway(idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, idx_t*, real_t*, real_t*, idx_t*, idx_t*, idx_t*)’
         );
         ^
make: *** [/home/happy/OpenFOAM/OpenFOAM-3.0.x/platforms/linux64GccDPInt64Opt/src/parallel/decompose/metisDecomp/metisDecomp.o] Error 1

Best regards!
Steps To ReproduceAlways shown
TagsNo tags attached.

Relationships

duplicate of 0002085 resolvedhenry metisDecomp compile error 

Activities

wyldckat

2017-03-05 14:51

updater   ~0007856

The issue with building METIS with 64-bit labels was fixed in OpenFOAM-dev and OpenFOAM 4.x's ThirdParty repository: https://github.com/OpenFOAM/ThirdParty-4.x/blob/master/Allwmake

See the related bug report #2085: https://bugs.openfoam.org/view.php?id=2085

wyldckat

2017-03-05 14:53

updater   ~0007857

Closing as duplicate and marking as already fixed as of 4.0.

Issue History

Date Modified Username Field Change
2017-03-05 01:05 popstar0426 New Issue
2017-03-05 14:51 wyldckat Note Added: 0007856
2017-03-05 14:52 wyldckat Relationship added duplicate of 0002085
2017-03-05 14:53 wyldckat Assigned To => wyldckat
2017-03-05 14:53 wyldckat Status new => closed
2017-03-05 14:53 wyldckat Resolution open => duplicate
2017-03-05 14:53 wyldckat Fixed in Version => 4.0
2017-03-05 14:53 wyldckat Note Added: 0007857