View Issue Details

IDProjectCategoryView StatusLast Update
0002478OpenFOAM[All Projects] Bugpublic2017-03-24 16:19
Reporterfsch1Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0002478: wrong limits in ThermoSurfaceFilm
DescriptionHello,
I was looking into the reference for the splashModel of the ThermoSurfaceFilm.

And there is a error in the limits for the transition states.

https://github.com/OpenFOAM/OpenFOAM-dev/blob/ea67173330a9ac6736df39780cee55beb8469e8e/src/lagrangian/intermediate/submodels/Thermodynamic/SurfaceFilmModel/ThermoSurfaceFilm/ThermoSurfaceFilm.C

The lines 308-312 should be changed from

    if (We < 1) // adhesion - assume absorb
    {
        absorbInteraction(filmModel, p, pp, facei, m, keepParticle);
    }
    else if ((We >= 1) && (We < 20)) // bounce

to

    if (We < 2) // adhesion - assume absorb
    {
        absorbInteraction(filmModel, p, pp, facei, m, keepParticle);
    }
    else if ((We >= 2) && (We < 20)) // bounce

according to the cited paper at "Table 1: Regime transition conditions" on page 3.

The paper:
http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.31.6230&rep=rep1&type=pdf
TagsNo tags attached.

Activities

henry

2017-03-24 12:58

manager   ~0007978

I checked Bai's thesis and it says the adhesion occurs for We ~1, not specifically 1 or 2. I do not have access to the reference

        Bai and Gosman, `Mathematical modelling of wall films formed by
        impinging sprays', SAE 960626, 1996

do you know if 1 or 2 is specified?

I am happy to change the criterion from 1 to 2 if you believe that it is necessary and provides improved results.

fsch1

2017-03-24 13:29

reporter   ~0007979

Hello,
I attached a screenshot from the table of the mentioned paper.

I think it's just important in some special cases. But nevertheless I thought it would be good to have consistency between the cited paper and the code..

screenshotBaiGosman.jpeg (247,614 bytes)
screenshotBaiGosman.jpeg (247,614 bytes)

henry

2017-03-24 13:49

manager   ~0007980

Last edited: 2017-03-24 13:50

View 2 revisions

The two papers listed in ThermoSurfaceFilm.H are

        Bai and Gosman, `Mathematical modelling of wall films formed by
        impinging sprays', SAE 960626, 1996

        Bai et al, `Modelling of gasoline spray impingement', Atom. Sprays,
        vol 12, pp 1-27, 2002

Do you have them both and do they both specify We = 2?

fsch1

2017-03-24 14:12

reporter   ~0007982

No I just have the newer on (from 2002) and there Bai says, they changed the transition values.
And in the newer model, they set it to We = 2

henry

2017-03-24 14:35

manager   ~0007983

> If you are interested in reading it...

Yes I have it from the link you originally posted, by I don't have

        Bai and Gosman, `Mathematical modelling of wall films formed by
        impinging sprays', SAE 960626, 1996

see above.

Have you run tests to check the influence of this value?

fsch1

2017-03-24 14:44

reporter   ~0007984

Sorry didn't understood you already have the paper from 2002.

And no, I didn't run tests, because I don't have a case with such small We-numbers.

I just saw the difference between the new paper and the implemented code (the other parts of the code are all based on the new paper) and thought it might be worth a bug report...

henry

2017-03-24 16:19

manager   ~0007985

Resolved by commit 78e40da8ac26bbcd06466c307c744dbd05a0f414

It is not completely clear that this change is necessary so if issues arise please open another bug-report and I will revert this change.

Issue History

Date Modified Username Field Change
2017-02-27 15:20 fsch1 New Issue
2017-03-24 12:58 henry Note Added: 0007978
2017-03-24 13:29 fsch1 File Added: screenshotBaiGosman.jpeg
2017-03-24 13:29 fsch1 Note Added: 0007979
2017-03-24 13:49 henry Note Added: 0007980
2017-03-24 13:50 henry Note Edited: 0007980 View Revisions
2017-03-24 14:12 fsch1 Note Added: 0007982
2017-03-24 14:35 henry Note Added: 0007983
2017-03-24 14:44 fsch1 Note Added: 0007984
2017-03-24 16:19 henry Assigned To => henry
2017-03-24 16:19 henry Status new => resolved
2017-03-24 16:19 henry Resolution open => fixed
2017-03-24 16:19 henry Fixed in Version => dev
2017-03-24 16:19 henry Note Added: 0007985