2017-02-28 16:50 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002460OpenFOAM[All Projects] Bugpublic2017-02-18 10:20
Reportersantiagomarquezd 
Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version 
Target VersionFixed in Version 
Summary0002460: Theoretical basis for fvc::reconstruct
DescriptionHello, here were are working with compressible solvers looking for improvements in stability which involves the use of the fvc::reconstruct operator. We've obtained good results and want to properly cite the original idea behind this operator but we couldn't find the theoretical basis in the literature, even more there is a missing explanation for this operator in the Programmer's Guide.

All we know comes from the code and some comments in cfd-online.com:

https://www.cfd-online.com/Forums/openfoam-programming-development/77943-fvc-reconstruct-algorithm.html

https://www.cfd-online.com/Forums/openfoam-programming-development/129159-fvc-reconstruct-algorithm.html

From this information we've elaborated some formulas and an explanation for the operator based on the idea of seeing reconstruct as an inverse operation for the interpolation.

If you offer some pointers to books or papers we'll be pleased to cite them.

Regards!
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0007758

henry (manager)

Please do not use this forum for support requests.

~0007759

santiagomarquezd (reporter)

Well, I would not be asking for this information if documentation were not buggy as is today, so I think it is not support, is documentation bug fixing.

~0007760

henry (manager)

Incomplete documentation is not a bug but if the documentation provided contains errors then that is a bug.

~0007761

santiagomarquezd (reporter)

So, in that case please remove the present entry for reconstruct from the Programmer's Guide since it only has its name but the formulas or explanations are missing (or maybe the idea is to have at least the list?)

Today it looks like this:

https://drive.google.com/file/d/0B2lpdhG-Zh05MmVjNm54N1ZRQVU/view?usp=sharing

 

~0007762

henry (manager)

It may be useful to people that the functionality is listed even if the description is incomplete but if it is generally felt that the entry should not be included in the list it could be removed in the next version of the Programmer's Guide.
+Notes

-Issue History
Date Modified Username Field Change
2017-02-15 23:14 santiagomarquezd New Issue
2017-02-15 23:35 henry Assigned To => henry
2017-02-15 23:35 henry Status new => closed
2017-02-15 23:35 henry Resolution open => no change required
2017-02-15 23:35 henry Note Added: 0007758
2017-02-15 23:45 santiagomarquezd Status closed => feedback
2017-02-15 23:45 santiagomarquezd Resolution no change required => reopened
2017-02-15 23:45 santiagomarquezd Note Added: 0007759
2017-02-15 23:58 henry Status feedback => closed
2017-02-15 23:58 henry Resolution reopened => no change required
2017-02-15 23:58 henry Note Added: 0007760
2017-02-16 00:16 santiagomarquezd Status closed => feedback
2017-02-16 00:16 santiagomarquezd Resolution no change required => reopened
2017-02-16 00:16 santiagomarquezd Note Added: 0007761
2017-02-16 00:26 henry Note Added: 0007762
2017-02-18 10:20 henry Status feedback => closed
2017-02-18 10:20 henry Resolution reopened => no change required
+Issue History