View Issue Details

IDProjectCategoryView StatusLast Update
0002446OpenFOAMPatchpublic2017-01-30 16:47
ReporterJuhoAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0002446: Wall boiling & IATE: FPE in restart
DescriptionIn reactingTwoPhaseEulerFoam wall boiling simulations with the IATE diameterModel the solver crashes on restart because wall phase change mass flux (dmdt) is present but departure diameter is zero because IATEsources::wallBoiling::R is called before the first turbulent wall function update.

To eliminate the issue I've attached a modified alphatWallBoilingWallFunction.C that writes and reads dDep so that when dmdt is present in start, dDep is also present.
TagsNo tags attached.

Activities

Juho

2017-01-30 13:50

reporter  

alphatWallBoilingWallFunctionFvPatchScalarField.C (21,249 bytes)

henry

2017-01-30 16:47

manager   ~0007695

Thanks Juho

Resolved by commit 457151db200134c75dc84fa515059ee4d894cb17

Issue History

Date Modified Username Field Change
2017-01-30 13:50 Juho New Issue
2017-01-30 13:50 Juho File Added: alphatWallBoilingWallFunctionFvPatchScalarField.C
2017-01-30 16:47 henry Assigned To => henry
2017-01-30 16:47 henry Status new => resolved
2017-01-30 16:47 henry Resolution open => fixed
2017-01-30 16:47 henry Fixed in Version => dev
2017-01-30 16:47 henry Note Added: 0007695