View Issue Details

IDProjectCategoryView StatusLast Update
0002436OpenFOAM[All Projects] Bugpublic2017-01-18 10:19
ReporterVojta_PrihodaAssigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.10
Product Version 
Fixed in Version 
Summary0002436: entropy calculation in eConstThermo doesnt work
DescriptionI did make some utility to which I needed entropy calculation. During this I found this minor bug:

In file eConstThermoI.H on line 149 in function inline Foam::scalar Foam::eConstThermo<EquationOfState>::s there is line

return cp()*log(T/Tstd) + EquationOfState::s(p, T);

where the cp() should be called with p and T as parameters, like this

return cp(p,T)*log(T/Tstd) + EquationOfState::s(p, T);

because function cp() does not exist (in this context).
TagsNo tags attached.

Activities

henry

2017-01-18 10:19

manager   ~0007650

Thanks for the report

Resolved in OpenFOAM-dev by 9d39850df36074c9deafdc4750acb2d564300fdc

Resolved in OpenFOAM-4.x by commit 100d9a9dd1ec83494cb73fde646242ce2de442b3

Issue History

Date Modified Username Field Change
2017-01-18 09:13 Vojta_Prihoda New Issue
2017-01-18 10:19 henry Assigned To => henry
2017-01-18 10:19 henry Status new => resolved
2017-01-18 10:19 henry Resolution open => fixed
2017-01-18 10:19 henry Fixed in Version => 4.x
2017-01-18 10:19 henry Note Added: 0007650