2018-03-21 03:12 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002423OpenFOAMFeaturepublic2017-09-20 18:48
Assigned Tohenry 
Product Version4.x 
Target VersionFixed in Version4.x 
Summary0002423: wallGradU
DescriptionI wonder if there is any particular reason why wallGradU is not in OF4x.
TagsNo tags attached.
Attached Files




henry (manager)

There is no particular need for it, the more general 'grad' is provided which includes the wall gradient.


wyldckat (updater)

Attached is the tarball 'contrib_bug2423.tar.gz' what provides two scripts for at least two of a few other missing references to utilities that were replaced, by using the existing reference scripts as a base:

 - bin/stressComponents

   Reproduced with "<solverName> -funcs '(R components(turbulenceProperties:R))'"

 - bin/wallGradU

   Reproduced with "postProcess -func 'grad(U)'"

 - Can be applied to 4.x and dev
 - I used the Copyright year only as it being 2017.

I then checked for OpenFOAM-dev and 'wdot' seemed to be the only other one missing, which is attached in 'contrib_bug2423_dev.tar.gz':

 - bin/wdot

   Reproduced with "postProcess -func XiReactionRate"

Beyond these:

 - 'uprime' and 'pPrime2' are still missing, but I couldn't figure out what they were replaced with exactly and the git history didn't provide detailed comments of what they were replaced with :(

 - 'dsmcFieldsCalc' I didn't even bother, because it didn't seem to be used by any tutorials, at least all the way back to 2.0.x.


henry (manager)

Resolved in OpenFOAM-dev by commit 80d540765a4b29d7e14af30526df3a797d892635

Resolved in OpenFOAM-4.x by commit d5dd04e0a63b88c2361182a6d74b429692202749


joegi (reporter)

I just would like to point out than when using

postProcess -func 'grad(U)' -noZero

It gives the following warning

--> FOAM Warning : functionObjects::grad grad(U) cannot find required object U of type volScalarField
--> FOAM Warning : functionObjects::grad grad(U) cannot find required object U of type surfaceScalarField

I guess is nothing to worry about as grad(U) is computed, but usually openfoam is very quiet so I worry a little bit when this kind of warnings.


wyldckat (updater)

It only warns until it finds what it was looking for... which can be seen here:

 - 'foundObject': https://github.com/OpenFOAM/OpenFOAM-dev/blob/146f7e6beaf592e4b17f606fa9794436be6de32f/src/functionObjects/field/fieldExpression/fieldExpressionTemplates.C#L30

 - 'calcGrad': https://github.com/OpenFOAM/OpenFOAM-dev/blob/146f7e6beaf592e4b17f606fa9794436be6de32f/src/functionObjects/field/grad/gradTemplates.C

 - How 'calc' calls 'calcGrad': https://github.com/OpenFOAM/OpenFOAM-dev/blob/146f7e6beaf592e4b17f606fa9794436be6de32f/src/functionObjects/field/grad/grad.C#L43

@joegi: Given the code listed above, what do you suggest should be done?


joegi (reporter)

Just to let you know that the header of grad(U) is also a little bit confusing. I got something like this:

# xx xy xz yx yy yz zx zy zzgrad(U)_0 grad(U)_1 grad(U)_2 grad(U)_3 grad(U)_4 grad(U)_5 grad(U)_6 grad(U)_7 grad(U)_8

I think the header should be something like this

#x y z grad(U)_0 grad(U)_1 grad(U)_2 grad(U)_3 grad(U)_4 grad(U)_5 grad(U)_6 grad(U)_7 grad(U)_8


wyldckat (updater)

@joegi: Sorry... but what exactly are you referring to? How did you get that output?

I ask this because running <tt>postProcess -func 'grad(U)'</tt> only writes the 'grad(U)' field!


joegi (reporter)

my bad, that is the output of a surface sampling of grad(U).


wyldckat (updater)

I'm setting this issue back to resolved+fixed as stated in comment ~7618, because I can't figure out to which function object @joegi was referring to in the previous comment.

@joegi: If you find this issue again, please create a new report and provide more details. I've looked for 15-20 minutes for this and could not find what kind of sampling you used.

-Issue History
Date Modified Username Field Change
2017-01-07 17:18 joegi New Issue
2017-01-07 17:37 henry Note Added: 0007605
2017-01-08 23:49 wyldckat File Added: contrib_bug2423.tar.gz
2017-01-08 23:49 wyldckat Note Added: 0007608
2017-01-08 23:49 wyldckat File Added: contrib_bug2423_dev.tar.gz
2017-01-08 23:49 wyldckat Assigned To => henry
2017-01-08 23:49 wyldckat Status new => assigned
2017-01-09 14:39 henry Status assigned => resolved
2017-01-09 14:39 henry Resolution open => fixed
2017-01-09 14:39 henry Fixed in Version => 4.x
2017-01-09 14:39 henry Note Added: 0007618
2017-01-12 18:37 joegi Status resolved => feedback
2017-01-12 18:37 joegi Resolution fixed => reopened
2017-01-12 18:37 joegi Note Added: 0007628
2017-01-12 23:49 wyldckat Note Added: 0007630
2017-01-15 19:07 joegi Note Added: 0007637
2017-01-15 19:07 joegi Status feedback => assigned
2017-01-15 22:37 wyldckat Note Added: 0007638
2017-01-16 06:54 joegi Note Added: 0007641
2017-02-20 20:49 wyldckat Status assigned => resolved
2017-02-20 20:49 wyldckat Resolution reopened => fixed
2017-02-20 20:49 wyldckat Note Added: 0007775
+Issue History