View Issue Details

IDProjectCategoryView StatusLast Update
0002395OpenFOAM[All Projects] Bugpublic2016-12-22 11:48
ReporterPFTAssigned Towyldckat 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformOSUbuntuOS Version16.04
Product Version 
Fixed in Version 
Summary0002395: Motorbike tutorial run from Allrun doesn't work
DescriptionOn OpenFoam 4.1 running on Ubuntu 16.04
Motorbike tutorial runs till the end using th script Allrun, but the motorbike itself is not there. Only can see the plain blocks from Paraview, no motorbike inside.
velocity lines are all straight.
Steps To Reproducecopy the Motorbike tutorial into the Run directory and run Allrun
TagsNo tags attached.

Activities

wyldckat

2016-12-15 12:42

updater   ~0007486

I have two requests, so it's easier to diagnose the problem:

 1. Please provide a snapshot of what you're seeing in ParaView. Please include ParaView itself. You can take a snapshot of ParaView by using the key combination Alt + Print Screen.

 2. Please provide the file "log.snappyHexMesh", so that we can compare with the one we get from our own run.

PFT

2016-12-18 07:17

reporter  

Screenshot from 2016-12-18 00-06-43.png (306,351 bytes)

PFT

2016-12-18 07:19

reporter  

log.snappyHexMesh (161,103 bytes)

PFT

2016-12-18 07:21

reporter   ~0007509

Attached as requested

wyldckat

2016-12-18 23:00

updater   ~0007512

Many thanks! This makes it a lot easier to diagnose.

Everything is fine according to the log file, which means that the motorbike geometry was meshed properly.

The screenshot you've provided demonstrates that you're looking at the wrong place. You were looking at a part which is well above the top of the rider's helmet.
I've attached the image "Clip_at_0.82m.png", which shows how you can configure the Clip filter to see the motorbike location. Notice the two red arrows, one for the height and the other for inverting the selection box of the "Clip" filter.

Please let us know if you can see the same.
Also, try using the "Y Normal" button, which should allow you to see the side view of the motorbike from inside out.


The only actual bug that I noticed has to do with the time snapshot, because it's referring to Time = 0, when it fact it should be 500, which is the only time step available. I'll open a separate patch report for that issue.

Clip_at_0.82m.png (210,709 bytes)
Clip_at_0.82m.png (210,709 bytes)

wyldckat

2016-12-19 01:57

updater   ~0007518

> The only actual bug that I noticed has to do with the time snapshot, because it's referring to Time = 0, when it fact it should be 500, which is the only time step available. I'll open a separate patch report for that issue.

The problem is in ParaView/VTK, not in OpenFOAM. I don't have enough time today to report this upstream.

wyldckat

2016-12-22 11:48

updater   ~0007548

@PFT: Please re-open this bug report if you cannot see the same as I described in comment ~7512.

I'm closing this report as "no change required".

Issue History

Date Modified Username Field Change
2016-12-15 11:13 PFT New Issue
2016-12-15 12:42 wyldckat Note Added: 0007486
2016-12-15 12:42 wyldckat OS => Ubuntu
2016-12-15 12:42 wyldckat OS Version => 16.04
2016-12-15 12:42 wyldckat Product Version => 4.1
2016-12-18 07:17 PFT File Added: Screenshot from 2016-12-18 00-06-43.png
2016-12-18 07:19 PFT File Added: log.snappyHexMesh
2016-12-18 07:21 PFT Note Added: 0007509
2016-12-18 23:00 wyldckat File Added: Clip_at_0.82m.png
2016-12-18 23:00 wyldckat Note Added: 0007512
2016-12-19 01:57 wyldckat Note Added: 0007518
2016-12-22 11:48 wyldckat Assigned To => wyldckat
2016-12-22 11:48 wyldckat Status new => closed
2016-12-22 11:48 wyldckat Resolution open => no change required
2016-12-22 11:48 wyldckat Note Added: 0007548