View Issue Details

IDProjectCategoryView StatusLast Update
0002372OpenFOAM[All Projects] Bugpublic2016-12-06 13:35
ReporterSebastian BuAssigned Tochris 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Version 
Summary0002372: paraFoam -block cannot load blockmesh plugin due to internal crash
DescriptionWhen running "paraFoam -block" there is an error when loading the required plugin:

    ERROR: In /home/openfoam/OpenFOAM/ParaView-5.0.1/ParaViewCore/ClientServerCore/Core/vtkPVPluginLoader.cxx, line 397
    vtkPVPluginLoader (0x1511ed0): /opt/openfoam-dev/platforms/linux64GccDPInt32Opt/lib/libedgeMesh.so: undefined symbol: _ZTIN4Foam5token8compoundE
    
    Failed to load data file: blockmeshscript-testcase.blockMesh

Additionally, ParaView opens a dialog asking for a reader ("A reader for [...]/blockmeshscript-testcase.blockMesh" could not be found. Pease choose one:"). When canceling this dialog, ParaView hasn't loaded anything.
Steps To ReproduceOpenFOAM-dev is installed by the apt repository as documented here: http://openfoam.org/download/dev-ubuntu/

Run

  paraFoam -block

in a OpenFOAM case directory for a case which uses blockMesh (system/blockMeshDict)
TagsNo tags attached.

Activities

Sebastian Bu

2016-12-06 08:15

reporter   ~0007409

dpkg info:

openfoam-dev 20161125

Sebastian Bu

2016-12-06 08:22

reporter   ~0007410

apt-get upgraded now to openfoam 20161205. Problem still occurs.

chris

2016-12-06 10:22

manager   ~0007412

The problem is that the core OpenFOAM library, libOpenFOAM.so is not getting linked to libPVblockMeshReader.so. Reordering the link libraries so that OpenFOAM comes last in PVblockMeshReader/PVblockMeshReader/CMakeLists.txt seems to fix the problem.

TARGET_LINK_LIBRARIES(
    PVblockMeshReader_SM
    LINK_PUBLIC
    blockMesh
    vtkPVblockMesh
    OpenFOAM
)

I will get this change pushed into OpenFOAM-dev and will build the openfoam-dev pack shortly.

chris

2016-12-06 11:15

manager   ~0007414

Fix pushed, building packs now...
https://github.com/OpenFOAM/OpenFOAM-dev/commit/f775751b511774299ccc08874a8cfd0c56a9388b

chris

2016-12-06 13:35

manager   ~0007418

Fixed in the latest openfoam-dev (20161206).

Thanks for reporting this critical issue.

Chris

Issue History

Date Modified Username Field Change
2016-12-05 14:56 Sebastian Bu New Issue
2016-12-06 08:15 Sebastian Bu Note Added: 0007409
2016-12-06 08:22 Sebastian Bu Note Added: 0007410
2016-12-06 10:22 chris Note Added: 0007412
2016-12-06 11:15 chris Note Added: 0007414
2016-12-06 13:35 chris Assigned To => chris
2016-12-06 13:35 chris Status new => closed
2016-12-06 13:35 chris Resolution open => fixed
2016-12-06 13:35 chris Note Added: 0007418