View Issue Details

IDProjectCategoryView StatusLast Update
0002323OpenFOAM[All Projects] Bugpublic2018-07-10 11:22
Reporternima.samkhanianiAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Versiondev 
Summary0002323: thermalBaffel1D
DescriptionI run a dynamicMesh problem similar movingCone using compressibelInterDyMFoam. I noticed that it failed after several iterations when i uses thermalBaffel1D,
I dont know why but the size of scalarField kappas and baffleThickness() in thermalBaffel1D becomes unequal and it is the source of error.

i solved this problem via replacing
The following code in thermalBaffle1DFvPatchScalarField.C
KDeltaSolid = kappas/baffleThickness();

with this

        scalarField KDeltaSolid(patch().size(), 0.0);
    scalarField alpha(patch().size(), 0.0);
    scalarField baffleThickness1=baffleThickness();
    forAll(kappas, i)
        {
            kappas[i] = solid().kappa(0.0, (Tp[i] + nbrTp[i])/2.0);
        KDeltaSolid[i] = kappas[i]/baffleThickness1[i]; //add
    }

   
TagsNo tags attached.

Activities

MattijsJ

2016-11-11 15:23

reporter   ~0007151

1) Can you attach a testcase?

2) Have you run your case through valgrind?

nima.samkhaniani

2016-11-21 18:22

reporter   ~0007270

1)The file is attached. It crashes before time 0.038

2)nope

movingPistonBaffel-compressibleInterDyMFoam.zip (103,149 bytes)

MattijsJ

2016-11-22 15:02

reporter   ~0007275

The problem is the underlying 'mapped' geometric matching which does not support topology changes out of the box so the mapping would still try to get data for 20 faces even though the patch was now 19 faces.

Attached fix for (dev) src/TurbulenceModels/compressible/turbulentFluidThermoModels/derivedFvPatchFields/thermalBaffle1D/thermalBaffle1DFvPatchScalarField.C will get around this.

We will have to think about where to fix this properly.

thermalBaffle1DFvPatchScalarField.C (12,230 bytes)

henry

2016-12-05 08:49

manager   ~0007404

Resolved in OpenFOAM-dev by commit 4a45e4f519feef615630ca50dc13f8f0517c17f9

Issue History

Date Modified Username Field Change
2016-11-08 15:00 nima.samkhaniani New Issue
2016-11-08 15:00 nima.samkhaniani Tag Attached: thermal baffel + dynamicMesh
2016-11-11 15:23 MattijsJ Note Added: 0007151
2016-11-21 18:22 nima.samkhaniani File Added: movingPistonBaffel-compressibleInterDyMFoam.zip
2016-11-21 18:22 nima.samkhaniani Note Added: 0007270
2016-11-22 15:02 MattijsJ File Added: thermalBaffle1DFvPatchScalarField.C
2016-11-22 15:02 MattijsJ Note Added: 0007275
2016-12-05 08:49 henry Assigned To => henry
2016-12-05 08:49 henry Status new => resolved
2016-12-05 08:49 henry Resolution open => fixed
2016-12-05 08:49 henry Fixed in Version => dev
2016-12-05 08:49 henry Note Added: 0007404
2018-07-10 11:22 administrator Tag Detached: thermal baffel + dynamicMesh