View Issue Details

IDProjectCategoryView StatusLast Update
0002298OpenFOAM[All Projects] Bugpublic2016-10-19 12:35
ReporterbaugierAssigned Towyldckat 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLINUXOSCentOSOS Version7.2.1511
Product Version 
Fixed in Version 
Summary0002298: Bug using paraFoam in the simpleFoam tuto motorBike and windAroundBuilding
DescriptionmotorBike and windAroundBuilding are running on the OF4.0. ParaView craches when opening the solution with the message error
cannot find 'value' entry on patch ground field U in file "myfile"
which is required to set the velues of the generic patch field.
(Actual type noSlip)

Please add the 'value' entry to the write function of the user-defined boundary-condition


Results can be opened with paraView adding manually in the 0/U and 100/ 200/ ... 400/U
type noSlip
value (0 0 0)
Additional InformationTuto are runned with OF4.0 on CentOS 7.2 and results are exported to be postprocessed on a Ubuntu 14.04 ParaView 4.1.0
TagsNo tags attached.

Activities

henry

2016-10-19 09:59

manager   ~0007033

I am unable to reproduce this problem, the cases post-process fine with ParaFoam using the reader module we supply with OpenFOAM. Which reader are you using?

wyldckat

2016-10-19 10:44

updater   ~0007034

@Henry: It's the same issue that occurred in #1867: http://bugs.openfoam.org/view.php?id=1867
In that case, the fix you applied has the following comment at the end:

    The current value is now written for post-processing convenience only.

This was and is because when using the built-in reader that ParaView has got, it looks for the "value" entry when it doesn't know the boundary type.

wyldckat

2016-10-19 10:46

updater   ~0007035

I forgot to mention that the built-in reader is aware of what "zeroGradient" is for, but that's pretty much it, if I remember correctly.

henry

2016-10-19 10:55

manager   ~0007037

The purpose of the 'noSlip' BC is to avoid the need to specify the zero value. If support for the 'noSlip' BC cannot be added to the built-in reader then the OpenFOAM reader supplied with OpenFOAM should be used.

baugier

2016-10-19 11:07

reporter   ~0007038

The viewer is ParaView 4.1.0 on Ubuntu 14.04 when Tuto are runned with OF4.0 on CentOS 7.2

wyldckat

2016-10-19 11:59

updater   ~0007040

@baugier: I agree with Henry, "noSlip" is categorically similar to "zeroGradient", so it's best to fix this upstream in VTK/ParaView. I've opened the bug report for it: https://gitlab.kitware.com/vtk/vtk/issues/16873

Therefore, since you're using Ubuntu 14.04, you can install the Deb packages as instructed here: http://openfoam.org/download/4-0-ubuntu/ - this is so that you use the same exact version as the one in CentOS 7.2. That way you can then open the cases properly, including those that use more complex boundary conditions.

The other workaround is to use foamToVTK to export the results to VTK format, to later open in ParaView.


Beyond this, a utility could be created for filling in the gap, namely to forcefully write the "value" entries, but that seems like an effort for something that would rarely be used.

wyldckat

2016-10-19 12:01

updater   ~0007041

Last edited: 2016-10-19 12:35

View 2 revisions

Closed as "No change required".

Issue History

Date Modified Username Field Change
2016-10-19 09:53 baugier New Issue
2016-10-19 09:59 henry Note Added: 0007033
2016-10-19 10:44 wyldckat Note Added: 0007034
2016-10-19 10:46 wyldckat Note Added: 0007035
2016-10-19 10:55 henry Note Added: 0007037
2016-10-19 11:07 baugier Note Added: 0007038
2016-10-19 11:59 wyldckat Note Added: 0007040
2016-10-19 12:01 wyldckat Assigned To => wyldckat
2016-10-19 12:01 wyldckat Status new => closed
2016-10-19 12:01 wyldckat Resolution open => won't fix
2016-10-19 12:01 wyldckat Note Added: 0007041
2016-10-19 12:35 henry Resolution won't fix => no change required
2016-10-19 12:35 henry Note Edited: 0007041 View Revisions