View Issue Details

IDProjectCategoryView StatusLast Update
0000229OpenFOAM[All Projects] Bugpublic2011-06-27 15:28
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000229: Misconfigured "Make/options" for applications
DescriptionAttached is a script for detecting misconfigured applications and libraries that have defined in "Make/options" LIB_LIBS where EXE_LIBS should be and vice-versa respectively.
The output on the latest commit is in the "Additional Information" section of this report.
Steps To ReproduceRun the attached script "trackBadEXELIB" on the base folder of the source code to be checked.
For opening the files directly in a text editor, e.g. with kate:
  trackBadLIBEXE | xargs -I {} kate -u {}/{options,files}
Additional InformationList of libraries that are misconfigured
List of applications that are misconfigured
./applications/utilities/mesh/generation/extrude/extrudeModel/Make
./applications/solvers/heatTransfer/chtMultiRegionFoam/coupledDerivedFvPatchFields/Make
./applications/solvers/compressible/rhoCentralFoam/BCs/Make
./src/regionModels/surfaceFilmModels/Make
./src/regionModels/regionModel/Make
./src/regionModels/pyrolysisModels/Make
./src/regionModels/thermoBaffleModels/Make
./src/regionModels/regionCoupling/Make
./src/lagrangian/molecularDynamics/molecule/Make
./src/postProcessing/postCalc/Make
./src/postProcessing/foamCalcFunctions/Make
./src/thermophysicalModels/barotropicCompressibilityModel/Make
./src/dummyThirdParty/MGridGen/Make
TagsNo tags attached.

Activities

wyldckat

2011-06-27 14:15

updater  

trackBadLIBEXE (736 bytes)
#!/bin/bash

# 1 - find bad application definitions
LIBRARIES=`find . -name options | xargs grep -e '^LIB_LIBS' -sl`

#go through the list and check which are "damaged"
echo "List of libraries that are misconfigured" >&2
for item in $LIBRARIES; do
  if [ "$(basename ${item%/*})" = "Make" -a -z "`grep -e "^LIB" ${item%/*}/files`" ]; then
    echo ${item%/*}
  fi
done


# 2 - find bad application definitions
APPLICATIONS=`find . -name options | xargs grep -e '^EXE_LIBS' -sl`

#go through the list and check which are "damaged"
echo "List of applications that are misconfigured" >&2
for item in $APPLICATIONS; do
  if [ "$(basename ${item%/*})" = "Make" -a -z "`grep -e "^EXE" ${item%/*}/files`" ]; then
    echo ${item%/*}
  fi
done
trackBadLIBEXE (736 bytes)

wyldckat

2011-06-27 14:26

updater   ~0000491

Since I'm feeling a bit lazy, I'll comment here instead of opening a new bug report:
  Wasn't the folder "wmake/rules/linuxmingw32" gone in 1.6.x and now back in 2.0.x? Anything you would want to share with us? ;)
  Or is it something as I suspect, that 2.0.x comes directly from before 1.6.x, developed in parallel with the released versions 1.6.x and 1.7.x?

henry

2011-06-27 15:28

manager   ~0000492

Thanks for the bug-report and search script.
Resolved by commit 6185905b131d6d8b9a306594e6c69144836c3d68

Issue History

Date Modified Username Field Change
2011-06-27 14:15 wyldckat New Issue
2011-06-27 14:15 wyldckat File Added: trackBadLIBEXE
2011-06-27 14:26 wyldckat Note Added: 0000491
2011-06-27 15:28 henry Note Added: 0000492
2011-06-27 15:28 henry Status new => resolved
2011-06-27 15:28 henry Resolution open => fixed
2011-06-27 15:28 henry Assigned To => henry