View Issue Details

IDProjectCategoryView StatusLast Update
0002289ThirdParty[All Projects] Bugpublic2016-10-11 08:42
ReporterzordiackAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Versiondev 
Fixed in Versiondev 
Summary0002289: Wrong CMAKE option for ParaView OpenGL2 backend in etc/tools/ParaViewFunctions
DescriptionThe new OpenGL2 rendering backend is not compiled in, because the name of the CMAKE option in file etc/tools/ParaViewFunctions is wrong. It says in http://www.paraview.org/Wiki/ParaView_Release_Notes#New_Rendering_Engine
that the CMAKE option to set is called "VTK_RENDERING_BACKEND", however in ParaViewFunctions it is called "VTK_RENDERING_BACKEND_DEFAULT" and it is not picked up. The following changes fixes the problem:

change

# Choose the new rendering engine
addCMakeVariable "VTK_RENDERING_BACKEND_DEFAULT=OpenGL2"

to

# Choose the new rendering engine
addCMakeVariable "VTK_RENDERING_BACKEND=OpenGL2"

After recompiling, the new rendering engine is used (ie Legacy rendering mode is no longer displayed).



Steps To ReproduceCompiling ParaView 5.x with makeParaView
TagsNo tags attached.

Activities

wyldckat

2016-10-10 23:44

updater   ~0006998

I can't believe I missed that!
Weirder still is that I wrote about a workaround on how to use OpenGL instead (seen here https://openfoamwiki.net/index.php/Installation/ParaView/FAQ ), because inside a virtual machine it was choosing OpenGL2 by default and it was giving me the following:

  Error message: "GL version 2.1 with the gpu_shader4 extension is not supported by your graphics driver"

So in my case it had selected the OpenGL v2 by default!

By the way, a workaround until this is fixed in the ThirdParty folder is to use this as an option for the "makeParaView" script, for example:

  ./makeParaView VTK_RENDERING_BACKEND=OpenGL2

Or:

  ./makeParaView VTK_RENDERING_BACKEND=OpenGL

henry

2016-10-11 08:42

manager   ~0006999

Resolved in ThirdParty-dev by commit 9639685e8fb511b45a7a16e8de00b4302854196f

Issue History

Date Modified Username Field Change
2016-10-10 13:38 zordiack New Issue
2016-10-10 23:44 wyldckat Note Added: 0006998
2016-10-11 08:42 henry Assigned To => henry
2016-10-11 08:42 henry Status new => resolved
2016-10-11 08:42 henry Resolution open => fixed
2016-10-11 08:42 henry Fixed in Version => dev
2016-10-11 08:42 henry Note Added: 0006999