2017-04-28 09:20 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002285OpenFOAMPatchpublic2016-10-10 10:42
Reporterwyldckat 
Assigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
StatusresolvedResolutionfixed 
Product Version4.x 
Target VersionFixed in Version4.x 
Summary0002285: FOAM_ETC set but not unset with wmUnset
DescriptionI'm not 100% certain if this was missed or if it's intended to stay defined, but FOAM_ETC is not unset when we use "wmUnset", namely the respective "unset" script.

If this is meant to remain set after clean up, we should add a little note about it.
If it's meant to also be unset, then I can have a patch for this later today.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006985

wyldckat (updater)

I've changed the report from Bug to Patch, since I'm now attaching the patch for fixing this issue.

The attached file "fix_unset_v1.tar.gz" provides the following files, which can be applied to both OpenFOAM 4.x and dev:

  - etc/config.csh/unset
  - etc/config.sh/unset

The changes made were:

  - unset the shell environment variable "FOAM_ETC", since this is not re-usable outside of the OpenFOAM shell environment for any of OpenFOAM's scripts in "bin" and "etc".

  - switched the order of "FOAM_CODE_TEMPLATES" with "FOAM_EXT_LIBBIN" and placed "FOAM_ETC" in-between, so that all variables on this block would be fully sorted alphabetically.

~0006993

henry (manager)

Resolved by commit 44281e24038da4a44d220ce0aa09237110dbe5b4

~0006996

wyldckat (updater)

Sorry to re-open, but this also affects OpenFOAM 4.x.
The previously attached package was originally tested with 4.x.

~0006997

henry (manager)

Resolved by commit 192edd160b93ee6a52d9a4e2554c9c09cc8587fd
+Notes

-Issue History
Date Modified Username Field Change
2016-10-07 10:17 wyldckat New Issue
2016-10-08 15:14 wyldckat Category Bug => Patch
2016-10-08 15:14 wyldckat File Added: fix_unset_v1.tar.gz
2016-10-08 15:18 wyldckat Note Added: 0006985
2016-10-08 15:19 wyldckat Assigned To => henry
2016-10-08 15:19 wyldckat Status new => assigned
2016-10-09 15:18 henry Status assigned => resolved
2016-10-09 15:18 henry Resolution open => fixed
2016-10-09 15:18 henry Fixed in Version => dev
2016-10-09 15:18 henry Note Added: 0006993
2016-10-10 10:39 wyldckat Status resolved => feedback
2016-10-10 10:39 wyldckat Resolution fixed => reopened
2016-10-10 10:39 wyldckat Note Added: 0006996
2016-10-10 10:42 henry Status feedback => resolved
2016-10-10 10:42 henry Resolution reopened => fixed
2016-10-10 10:42 henry Fixed in Version dev => 4.x
2016-10-10 10:42 henry Note Added: 0006997
+Issue History