View Issue Details

IDProjectCategoryView StatusLast Update
0002237OpenFOAM[All Projects] Bugpublic2016-09-12 13:34
ReporterfsalmonAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform/OSLinux MintOS Version17.1
Product Version 
Fixed in Versiondev 
Summary0002237: Problem with the combustion model FSD and LES
DescriptionI have a case of combustion. I tried to run the case with the model of infinitely fast chemistry and it worked (infinitelyFastChemistry<psiThermoCombustion,gasHThermoPhysics>).
I just change into FSD<psiThermoCombustion,gasHThermoPhysics> and it does not work anymore. There is a problem with LES:


FOAM FATAL ERROR:

    request for LES LESProperties from objectRegistry region0 failed
    available objects of type LES are
1(turbulenceProperties)
TagsCombustion

Activities

fsalmon

2016-09-07 09:16

reporter  

log.foamExec (22,109 bytes)

fsalmon

2016-09-07 09:17

reporter  

0.tar.gz (1,811 bytes)

fsalmon

2016-09-07 09:18

reporter  

combustionProperties (1,731 bytes)
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  3.0.1                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version     2.0;
    format      ascii;
    class       dictionary;
    location    "constant";
    object      combustionProperties;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

//combustionModel  infinitelyFastChemistry<psiThermoCombustion,gasHThermoPhysics>;
combustionModel  FSD<psiThermoCombustion,gasHThermoPhysics>;

active true;

infinitelyFastChemistryCoeffs
{
    C       2;
    semiImplicit    false;
}

FSDCoeffs
{
    Cv          0.1;
    ftVarMin    1e-2;
    semiImplicit    true;
    reactionRateFlameArea relaxation;

    fuel                Propane;

    relaxationCoeffs
    {
        C                     2.0;
        alpha                 1.0;

        Methane
        {
            omega0            0.5;
            eta               -0.013;
            omegaMin          0.01;
            sigmaExt          470;
        }
        Propane
        {
            omega0            0.4;
            eta               -0.00656;
            omegaMin          0.01;
            sigmaExt          450;
        }
    }
}

// ************************************************************************* //
combustionProperties (1,731 bytes)

fsalmon

2016-09-07 09:18

reporter  

turbulenceProperties (2,110 bytes)
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  3.0.1                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/

FoamFile
{
    version     2.0;
    format      ascii;
    class       dictionary;
    location    "constant";
    object      turbulenceProperties;
}

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

simulationType  LES;

LES
{
    LESModel        kEqn;

    delta           cubeRootVol;

    turbulence      on;

    printCoeffs     on;

    kEqnCoeffs
    {
        Prt             1;
    }

    cubeRootVolCoeffs
    {
        deltaCoeff      1;
    }

    PrandtlCoeffs
    {
        delta           cubeRootVol;
        cubeRootVolCoeffs
        {
            deltaCoeff      1;
        }

        smoothCoeffs
        {
            delta           cubeRootVol;
            cubeRootVolCoeffs
            {
                deltaCoeff      1;
            }

            maxDeltaRatio   1.1;
        }

        Cdelta          0.158;
    }

    vanDriestCoeffs
    {
        delta           cubeRootVol;
        cubeRootVolCoeffs
        {
            deltaCoeff      1;
        }

        smoothCoeffs
        {
            delta           cubeRootVol;
            cubeRootVolCoeffs
            {
                deltaCoeff      1;
            }

            maxDeltaRatio   1.1;
        }

        Aplus           26;
        Cdelta          0.158;
    }

    smoothCoeffs
    {
        delta           cubeRootVol;
        cubeRootVolCoeffs
        {
            deltaCoeff      1;
        }

        maxDeltaRatio   1.1;
    }
}

// ************************************************************************* //
turbulenceProperties (2,110 bytes)

fsalmon

2016-09-07 09:19

reporter  

omega (1,510 bytes)
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  3.0.1                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version     2.0;
    format      ascii;
    class       volScalarField;
    location    "0";
    object      omega;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


dimensions      [1 -2 -1 0 0 0 0];

internalField   uniform 0;

boundaryField
{
    ground
    {
        type            fixedValue;//omegaWallFunction;
        value           $internalField;
    }

    top
    {
        type            fixedValue;//omegaWallFunction;
        value           $internalField;
    }

    burner
    {
        type            fixedValue;
        value           $internalField;
    }

    sides
    {
        type            fixedValue;//omegaWallFunction;
        value           $internalField;
    }

    "(region0_to.*)"
    {
        type            omegaWallFunction;
        value           $internalField;
    }
}

// ************************************************************************* //
omega (1,510 bytes)

fsalmon

2016-09-07 09:21

reporter   ~0006837

I attach some files that I consider to be important.

I have a big doubt concerning the file omega that I had to add because the FSD model demands it.

fsalmon

2016-09-07 10:56

reporter   ~0006838

I forgot to say that I use fireFoam

henry

2016-09-07 11:00

manager   ~0006839

Could you setup one of the tutorial cases in OpenFOAM-4.x or OpenFOAM-dev to reproduce the problem?

fsalmon

2016-09-08 09:56

reporter   ~0006848

Thanks for your quick reply.

Do you really think that the problem comes from the version ? Because I have an error with the installation of OpenFOAM.4-0 (and a problem with paraview5.0.1). I can try to fix it or to install OpenFOAM-dev.

henry

2016-09-08 10:09

manager   ~0006849

I do not know if the problem is version related but either way I will work on it in OpenFOAM-4.x or OpenFOAM-dev using a tutorial case if you can reproduce the problem.

fsalmon

2016-09-09 13:47

reporter   ~0006853

I have installed OpenFOAM dev.
I run tutorial cases (smallPoolFire2D and 3D).

It runs when I change nothing.
Then, I changed infinitely into FSD in "combustionProperties", I added some lines in fvScheme and added an omega file (only for the 3D case). The cases run but they seem to stop their progression: the last line of my log.fireFoam is "GAMG: Solving for ILambda_15_0, Initial residual = 1, Final residual = 5.12474e-15, No Iterations 1". But there is no crash.

This is the same for my personal case whereas it was not with OpenFOAM-3.0.1.

fsalmon

2016-09-09 14:06

reporter  

log.fireFoam_3.0.1 (12,613 bytes)

fsalmon

2016-09-09 14:06

reporter  

log.fireFoam_dev (11,741 bytes)

fsalmon

2016-09-09 14:07

reporter   ~0006854

I added both log.fireFoam files fore 3.0.1 and dev.

henry

2016-09-09 16:26

manager   ~0006855

Resolved in OpenFOAM-dev by commit 017281a11652cfc2e202c1ce4586326cf61c84e4

    combustionModels/FSD: Corrected
    Renamed 'omega' to 'FSDomega' to avoid a clash with the k-omega
    turbulence models.

let me know if it now works for your case also.

fsalmon

2016-09-12 12:53

reporter   ~0006856

Thank you, it works !

You can close the issue.

Issue History

Date Modified Username Field Change
2016-09-07 09:13 fsalmon New Issue
2016-09-07 09:13 fsalmon Tag Attached: Combustion
2016-09-07 09:16 fsalmon File Added: log.foamExec
2016-09-07 09:17 fsalmon File Added: 0.tar.gz
2016-09-07 09:18 fsalmon File Added: combustionProperties
2016-09-07 09:18 fsalmon File Added: turbulenceProperties
2016-09-07 09:19 fsalmon File Added: omega
2016-09-07 09:21 fsalmon Note Added: 0006837
2016-09-07 10:56 fsalmon Note Added: 0006838
2016-09-07 11:00 henry Priority high => normal
2016-09-07 11:00 henry Severity block => major
2016-09-07 11:00 henry Note Added: 0006839
2016-09-08 09:56 fsalmon Note Added: 0006848
2016-09-08 10:09 henry Note Added: 0006849
2016-09-09 13:47 fsalmon Note Added: 0006853
2016-09-09 14:06 fsalmon File Added: log.fireFoam_3.0.1
2016-09-09 14:06 fsalmon File Added: log.fireFoam_dev
2016-09-09 14:07 fsalmon Note Added: 0006854
2016-09-09 16:26 henry Note Added: 0006855
2016-09-12 12:53 fsalmon Note Added: 0006856
2016-09-12 13:34 henry Assigned To => henry
2016-09-12 13:34 henry Status new => resolved
2016-09-12 13:34 henry Resolution open => fixed
2016-09-12 13:34 henry Fixed in Version => dev