View Issue Details

IDProjectCategoryView StatusLast Update
0002202OpenFOAM[All Projects] Bugpublic2016-08-20 08:52
ReporterwangmuyangAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Fixed in Version 
Summary0002202: Allwmake: command not found
DescriptionI followed the guide on http://openfoam.org/download/4-0-source/. The question existed again.

cherry@wangchangchang:~/OpenFOAM/OpenFOAM-4.0$ Allwmake -help
Allwmake: command not found
cherry@wangchangchang:~/OpenFOAM/OpenFOAM-4.0$ cd $HOME/OpenFOAM/OpenFOAM-4.0/
cherry@wangchangchang:~/OpenFOAM/OpenFOAM-4.0$ Allwmake
Allwmake: command not found
cherry@wangchangchang:~/OpenFOAM/OpenFOAM-4.0$ ./Allwmake
./Allwmake: 7: .: Can't open /wmake/scripts/AllwmakeParseArguments
cherry@wangchangchang:~/OpenFOAM/OpenFOAM-4.0$
TagsNo tags attached.

Activities

wyldckat

2016-08-19 17:38

updater   ~0006705

What does this command give you?

  source $HOME/OpenFOAM/OpenFOAM-4.0/etc/bashrc

Does it give you any error messages?

wyldckat

2016-08-19 19:30

updater   ~0006706

And after you run that command, what do the following commands give you?

  echo $FOAM_INST_DIR
  echo $WM_PROJECT_DIR

If they give you any output, it should be this:

  /home/cherry/OpenFOAM
  /home/cherry/OpenFOAM/OpenFOAM-4.0

If it is the same output, you should now be able to properly follow the installation instructions.

wangmuyang

2016-08-20 07:40

reporter   ~0006709

Thank you very much! After I reboot my system Ubuntu 14.04LTS, following the instructions, this problem has been solved. May be the cause that I put the command sudo add-apt-repository http://dl.openfoam.org/ubuntu
sudo sh -c "wget -O - http://dl.openfoam.org/gpg.key | apt-key add -" on http://openfoam.org/download/source/third-party-software/ firstly. I have spent one week on this problem, now I am so happy. What's more, I find this platform for me. I think my OpenFOAM way will be much easier. Thanks again!

Issue History

Date Modified Username Field Change
2016-08-19 10:34 wangmuyang New Issue
2016-08-19 17:38 wyldckat Note Added: 0006705
2016-08-19 19:30 wyldckat Note Added: 0006706
2016-08-20 07:40 wangmuyang Note Added: 0006709
2016-08-20 08:52 henry Status new => closed
2016-08-20 08:52 henry Assigned To => henry
2016-08-20 08:52 henry Resolution open => no change required