2017-07-23 13:34 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002192OpenFOAMPatchpublic2016-08-16 08:47
Reporterwyldckat 
Assigned Tohenry 
PrioritylowSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version4.x 
Target VersionFixed in Version4.x 
Summary0002192: "GUI resource files in plugins are no longer supported" resurfaced in plugins when built with ParaView 5.0
DescriptionBack in report #2140, there was a warning shown in the report that seemed strange:

  CMake Warning at /home/ofuser/OpenFOAM/ThirdParty-4.x/platforms/linux64Gcc/ParaView-5.0.1/lib/cmake/paraview-5.0/ParaViewPlugins.cmake:988 (message):
    GUI resource files in plugins are no longer supported. The same
    functionality can be obtained using Hints in the Server Manager xml files.
    See the Major API Changes document for details.
  Call Stack (most recent call first):
    CMakeLists.txt:59 (ADD_PARAVIEW_PLUGIN)

Upon further inspection, this issue was introduced when a partial fix was applied in OpenFOAM 2.3.x, namely for dealing with build differences between ParaView 4.0.* and 4.1.0, when the "GUI_RESOURCE_FILES" option was deprecated in ParaView's CMake stack. The fix made at the time only checked for "PARAVIEW_VERSION_MINOR" being equal or not to 0.

This was not a problem while ParaView 4 was still the major version, but with the subsequent support for ParaView 5.0 and newer, this warning popped up once again.

Therefore, attached is the tarball "PV_Readers_update.tar.gz" which provides a simple fix for the following files (applicable to both OpenFOAM-4.x and OpenFOAM-dev repositories):

  applications/utilities/postProcessing/graphics/PVReaders/PVFoamReader/PVFoamReader/CMakeLists.txt
  applications/utilities/postProcessing/graphics/PVReaders/PVblockMeshReader/PVblockMeshReader/CMakeLists.txt


The fix is essentially this:

  -IF("${PARAVIEW_VERSION_MINOR}" EQUAL 0)
  +IF("${PARAVIEW_VERSION_MAJOR}.${PARAVIEW_VERSION_MINOR}" EQUAL 4.0)

This was tested with success, when changed on purpose to 5.0 instead of 4.0.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006673

henry (manager)

Thanks for the fix Bruno; this minor irritation was on my list but I hadn't got around to it.

Resolved in OpenFOAM-4.x by commit c84098737c7b1a0521d7793719efc74687e5c8b0
Resolved in OpenFOAM-dev by commit 813baea823b8ed91c23c6fa58683db2f7741093e
+Notes

-Issue History
Date Modified Username Field Change
2016-08-15 21:30 wyldckat New Issue
2016-08-15 21:30 wyldckat Status new => assigned
2016-08-15 21:30 wyldckat Assigned To => henry
2016-08-15 21:30 wyldckat File Added: PV_Readers_update.tar.gz
2016-08-16 08:47 henry Note Added: 0006673
2016-08-16 08:47 henry Status assigned => resolved
2016-08-16 08:47 henry Fixed in Version => 4.x
2016-08-16 08:47 henry Resolution open => fixed
+Issue History