View Issue Details

IDProjectCategoryView StatusLast Update
0002172OpenFOAM[All Projects] Bugpublic2016-08-03 20:21
Reportereric.trw82Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0002172: reactingFoam of openfoam4 does not reproduce similar results from openfoam 3.0.1
DescriptionI restarted a previous calculation using reactingFoam openfoam 3.0.1 for a supersonic combustion test case with the latest openfoam 4.0. The results from openfoam 4.0 fails to converged after 50 PIMPLE itereations while the older openfoam 3.0.1 results showed convergence after 12 PIMPLE iterations. I tried turning yes and no the "consistent" flag in PIMPLE control (in fvSolution file) and there is no difference in the openfoam 4.0 non-convergence behavior.
Additional Informationattached file contains 3 separate files, namely: log file from Openfoam 3.0.1 run, fvSolution file (starting from line 3070) and log file from Openfoam 4.0.
TagsNo tags attached.

Activities

eric.trw82

2016-08-01 18:58

reporter  

log3.0.1_plus_fvsolution_plus_log4 (1,543,400 bytes)

henry

2016-08-01 20:05

manager   ~0006600

Can you reproduce the issue on a simple case you can provide?
Do you see any difference in behavior for the tutorial case?

Which ODE solver are you running with?

eric.trw82

2016-08-01 20:20

reporter   ~0006602

I can try a simple tutorial test case but then it may not have similar pimple controls I have. I use seulex for Ode. Will get back to you soon as I am free.

henry

2016-08-01 20:24

manager   ~0006603

Could you run your case in OpenFOAM-4.x?

eric.trw82

2016-08-03 00:59

reporter   ~0006621

I found a good simple testcase for your testing. It is the "pitzDaily" case where I downloaded by typing in an Unix platform: wget http://openfoamwiki.net/images/b/b6/ReactingFoamCase.tar.gz I had to modify some files to make them compatible to Foam3.0.1 (or foam 4.0). I have also attached the modified "fvsolution" file where the PIMPLE controls are specified. What I actually now know is that it is the "momentumPredictor" being turned "yes" taht caused the differences between 3.0.1 and 4.0. In other words, if "momentumPredictor" is "no" there is no discernible differences between the 2 versions of OpenFoam. Let me know if I can be of further help.
p.s. if you have a public ftp site I can dump all the files I used. let me know.

henry

2016-08-03 08:40

manager   ~0006622

Have you tested the case with OpenFOAM-4.x?

henry

2016-08-03 09:05

manager   ~0006624

The pitzDaily case you refer to is VERY VERY old and will not run with a recent version of OpenFOAM without a complete rewrite. I do not know what settings you are running for the reaction modeling and so cannot reproduce your setup. Please remove the mesh files and any time dumps and then the case should be small enough to attach here.

eric.trw82

2016-08-03 14:40

reporter   ~0006628

Yes I did try on foam 3.0.1 and 4.0. I got essentially the same differences as in my own case reported in the beginning. As I said I can give you all the pitsdaily files if you have a public ftp site.

henry

2016-08-03 15:02

manager   ~0006629

Have you tested the case with OpenFOAM-4.x?
https://github.com/OpenFOAM/OpenFOAM-4.x

> As I said I can give you all the pitsdaily files if you have a public ftp site.

We do not have a public ftp site but if you remove all large files which can be recreated, e.g. results and mesh files generated by blockMesh, you should be able to attach the case here.

eric.trw82

2016-08-03 15:11

reporter   ~0006631

This big reporting site only allows one file to be attached. I Will have to cat all the files. Let me work on it later. Please pay close attention what I described as culprit of the problem.

henry

2016-08-03 15:30

manager   ~0006632

> This big reporting site only allows one file to be attached.

Lots of people have attached more than one file; what gives you the impression that this is not possible?

> Please pay close attention what I described as culprit of the problem.

I need to have the cases to investigate. What do you think the culprit is? Do you see the same problem with OpenFOAM-4.x?

eric.trw82

2016-08-03 16:36

reporter   ~0006634

i just uploaded 4 files: 0_dir, constant_dir, system_dir and chemkin_dir. Break them up and put them in proper folders as indicated by the file names. This should work on your Foam4.0. For foam3.0.1, it is the same files except that your may have to remove the "CHEMKINTransportFile" line in constant/thermophysicalProperties file. this file is not needed for foam 3.0.1. good luck.

henry

2016-08-03 16:46

manager   ~0006635

I will run the test is OpenFOAM-4.x. Do you see the same problem when you run the case in OpenFOAM-4.x?

henry

2016-08-03 17:14

manager   ~0006637

What are these files you attached? They do not appear to be tar or zip packs:

file system_dir
system_dir: ASCII text

tar -xzf system_dir
gzip: stdin: not in gzip format

unzip -l system_dir
Archive: system_dir
  End-of-central-directory signature not found. Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive. In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of system_dir or
        system_dir.zip, and cannot find system_dir.ZIP, period.

Could you let us know how they should be unpacked?

It would be easier if you supplied the complete case as a single tar-gzip file.

eric.trw82

2016-08-03 18:04

reporter  

pitzDaily.tar.gz (1,534,862 bytes)

eric.trw82

2016-08-03 18:11

reporter   ~0006638

please read my previous note regarding these *_dir files. they are catennated ascii files from corresponding system/, 0/, constant/, and chemkin/. You need to bring them up into an ascii editor and separate them out. Here is the tar file you wanted. I did do it that way earlier because I have lot other stuffs including which would exceed your 2 Mb file limitation. Anyway I clean up all my folders and all the files are here. Again, please read carefully what I wrote previously.

henry

2016-08-03 18:19

manager   ~0006639

> You need to bring them up into an ascii editor and separate them out.

That's crazy! Why not use tar or zip?

> Again, please read carefully what I wrote previously.

I have read carefully what you wrote previously but I still don't know if you see the same problem when you run the case in OpenFOAM-4.x. Please answer this question as it could save a lot of time.

eric.trw82

2016-08-03 18:28

reporter   ~0006640

my previous comment: "eric.trw82 (reporter)
2016-08-03 13:40
      
 Yes I did try on foam 3.0.1 and 4.0. I got essentially the same differences as in my own case reported in the beginning. As I said I can give you all the pitsdaily files if you have a public ftp site. "
Again, running the pitzdaily test case on 3.0.1 and 4.0 will more of less reproduce the differences I described originally.

henry

2016-08-03 18:30

manager   ~0006641

I understand you tried 3.0.1 and 4.0 but have you tried 4.x? 4.x is 4.x NOT 4.0:
https://github.com/OpenFOAM/OpenFOAM-4.x

henry

2016-08-03 20:21

manager   ~0006646

This issue is trivial: pressure relaxation is not supported in reactingFoam in OpenFOAM-3.0.? but it is in OpenFOAM-4.?. So to run reactingFoam in OpenFOAM-4.? in the same manner as OpenFOAM-3.0.? simply don't relax the pressure:

relaxationFactors
{
    fields
    {
        //p 0.3;
        //pFinal 1;
      Yi 0.2;
      YiFinal 1;
    }
.
.
.

Issue History

Date Modified Username Field Change
2016-08-01 18:58 eric.trw82 New Issue
2016-08-01 18:58 eric.trw82 File Added: log3.0.1_plus_fvsolution_plus_log4
2016-08-01 20:05 henry Note Added: 0006600
2016-08-01 20:20 eric.trw82 Note Added: 0006602
2016-08-01 20:24 henry Note Added: 0006603
2016-08-03 00:59 eric.trw82 Note Added: 0006621
2016-08-03 08:40 henry Note Added: 0006622
2016-08-03 09:05 henry Note Added: 0006624
2016-08-03 14:40 eric.trw82 Note Added: 0006628
2016-08-03 15:02 henry Note Added: 0006629
2016-08-03 15:11 eric.trw82 Note Added: 0006631
2016-08-03 15:30 henry Note Added: 0006632
2016-08-03 16:28 eric.trw82 File Added: 0_dir
2016-08-03 16:28 eric.trw82 File Added: chemkin_dir
2016-08-03 16:28 eric.trw82 File Added: constant_dir
2016-08-03 16:29 eric.trw82 File Added: system_dir
2016-08-03 16:36 eric.trw82 Note Added: 0006634
2016-08-03 16:46 henry Note Added: 0006635
2016-08-03 17:14 henry Note Added: 0006637
2016-08-03 18:04 eric.trw82 File Added: pitzDaily.tar.gz
2016-08-03 18:11 eric.trw82 Note Added: 0006638
2016-08-03 18:19 henry Note Added: 0006639
2016-08-03 18:23 henry File Deleted: 0_dir
2016-08-03 18:23 henry File Deleted: chemkin_dir
2016-08-03 18:23 henry File Deleted: constant_dir
2016-08-03 18:23 henry File Deleted: system_dir
2016-08-03 18:28 eric.trw82 Note Added: 0006640
2016-08-03 18:30 henry Note Added: 0006641
2016-08-03 20:21 henry Note Added: 0006646
2016-08-03 20:21 henry Status new => resolved
2016-08-03 20:21 henry Resolution open => no change required
2016-08-03 20:21 henry Assigned To => henry