View Issue Details

IDProjectCategoryView StatusLast Update
0002168OpenFOAMPatchpublic2016-08-01 17:07
ReporterwyldckatAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.x 
Fixed in Version4.x 
Summary0002168: src/fvAgglomerationMethods/Allwmake still references unused Scotch environment
DescriptionFrom what I can figure out, the "scotchGamgAgglomeration" was something that was started back in 2013, but wasn't completed. Nonetheless, remnant references to it have been on this Allwmake file for sometime now and the previous change only removed the explicit reference to that library.

Attached is the updated file "Allwmake" to replace "src/fvAgglomerationMethods/Allwmake" in 4.x, which removes the sourcing of the Scotch environment, which is not used, given that "scotchGamgAgglomeration" doesn't exist :(

The attached file is mostly applicable to OpenFOAM-dev, but the "targetType=libso" line (~5th line) isn't needed in OpenFOAM-dev.
TagsNo tags attached.

Activities

wyldckat

2016-08-01 16:14

updater  

Allwmake (458 bytes)
#!/bin/sh
cd ${0%/*} || exit 1    # Run from this directory

# Parse arguments for library compilation
targetType=libso
. $WM_PROJECT_DIR/wmake/scripts/AllwmakeParseArguments
set -x

export ParMGridGen=$WM_THIRD_PARTY_DIR/ParMGridGen-1.0

if [ -e "$FOAM_LIBBIN/libMGridGen.so" ]
then
    wmake $targetType MGridGenGamgAgglomeration
fi

wmake $targetType pairPatchAgglomeration

#------------------------------------------------------------------------------
Allwmake (458 bytes)

henry

2016-08-01 16:34

manager   ~0006592

Unfortunately the agglomeration method provided by scotch still doesn't work which is why we have not included the interface to it. We hope at some point in the future this part of scotch will be fixed and we will then release an interface to it. In the meantime I guess all references to the building of it can be removed.

wyldckat

2016-08-01 16:53

updater   ~0006593

Many thanks for the details!
I did think that the agglomeration algorithm was meant to be mostly set-up on OpenFOAM's side and that Scotch only had to sort out the graphs based on the relation weights. This was why I did think that the code hadn't been completed due to the complexity of the preparation algorithm (i.e. not enough funding or time).

The other possibility would be to bring back in commented form the line for building "scotchGamgAgglomeration", but I can't find any public signs on there being any work being done on this from Scotch's development side, at least not under the name of "agglomeration".

henry

2016-08-01 17:00

manager   ~0006594

As far as I am aware the agglomeration functionality in scotch is not being developed at the moment, in fact it looks like scotch is now only being maintained. I hope that scotch development restarts at some point and the work on the agglomeration is completed/debugged.

henry

2016-08-01 17:07

manager   ~0006595

Resolved in OpenFOAM-4.x by commit 5a6fdc1dad546cee5601bcfecf64847251082f3b
Resolved in OpenFOAM-dev by commit 26f706da432d5b017ec7f7b08d77f7eafcb68b11

Issue History

Date Modified Username Field Change
2016-08-01 16:14 wyldckat New Issue
2016-08-01 16:14 wyldckat Status new => assigned
2016-08-01 16:14 wyldckat Assigned To => henry
2016-08-01 16:14 wyldckat File Added: Allwmake
2016-08-01 16:34 henry Note Added: 0006592
2016-08-01 16:53 wyldckat Note Added: 0006593
2016-08-01 17:00 henry Note Added: 0006594
2016-08-01 17:07 henry Note Added: 0006595
2016-08-01 17:07 henry Status assigned => resolved
2016-08-01 17:07 henry Fixed in Version => 4.x
2016-08-01 17:07 henry Resolution open => fixed