View Issue Details

IDProjectCategoryView StatusLast Update
0002135OpenFOAM[All Projects] Bugpublic2016-07-01 10:40
ReporterjherbAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version12.3
Product Version 
Fixed in Version 
Summary0002135: OpenFOAM 4.x (2ac98b541d3f1aa0959504d8d3c6029ce0772269) does not compile
DescriptionThe compilation of OpenFOAM 4.x fails with the following error message:
g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offset
of -O3 -DNoRepository -ftemplate-depth-100 -I/home/hej/OpenFOAM/ThirdParty-4.x/platforms/linux64Gcc/boost-system/include -I/home/hej/OpenFOAM/OpenFOAM-4.x/src/meshTool
s/lnInclude -I/home/hej/OpenFOAM/OpenFOAM-4.x/src/parallel/decompose/decompositionMethods/lnInclude -I/home/hej/OpenFOAM/OpenFOAM-4.x/src/renumber/renumberMethods/lnInc
lude -IlnInclude -I. -I/home/hej/OpenFOAM/OpenFOAM-4.x/src/OpenFOAM/lnInclude -I/home/hej/OpenFOAM/OpenFOAM-4.x/src/OSspecific/POSIX/lnInclude -fPIC -shared -Xlinker
--add-needed -Xlinker --no-as-needed /home/hej/OpenFOAM/OpenFOAM-4.x/platforms/linux64GccDPInt32Opt/src/renumber/SloanRenumber/SloanRenumber.o -L/home/hej/OpenFOAM/Open
FOAM-4.x/platforms/linux64GccDPInt32Opt/lib \
            -L/home/hej/OpenFOAM/ThirdParty-4.x/platforms/linux64Gcc/boost-system/lib -lboost_thread -lmeshTools -ldecompositionMethods -lrenumberMethods -o /home/hej/
OpenFOAM/OpenFOAM-4.x/platforms/linux64GccDPInt32Opt/lib/libSloanRenumber.so
/usr/bin/ld: cannot find -lboost_thread
Steps To Reproducecd $WM_PROJECT_DIR
./Allwmake
Additional InformationThe problem can be solved by adding a link in $BOOST_ARCH_PATH/lib:
ln -s libboost_system.so libboost_thread.so

So libboost_system.so is build but a library named libboost_thread.so is expected.
TagsNo tags attached.

Activities

henry

2016-06-30 11:12

manager   ~0006476

Are you compiling with the system boost or are you building boost from sources in ThirdParty?

henry

2016-06-30 12:02

manager   ~0006477

It looks like libboost_system.so is sufficient for SloanRenumber so I have changed the link-line:

commit 4bb9e66c24724519658268dfd81aa7979fbfe80a

let me know if this resolves the problem.

henry

2016-07-01 10:40

manager   ~0006482

Resolved by commit 4bb9e66c24724519658268dfd81aa7979fbfe80a

Issue History

Date Modified Username Field Change
2016-06-30 11:08 jherb New Issue
2016-06-30 11:12 henry Note Added: 0006476
2016-06-30 12:02 henry Note Added: 0006477
2016-07-01 10:40 henry Note Added: 0006482
2016-07-01 10:40 henry Status new => resolved
2016-07-01 10:40 henry Fixed in Version => 4.x
2016-07-01 10:40 henry Resolution open => fixed
2016-07-01 10:40 henry Assigned To => henry