View Issue Details

IDProjectCategoryView StatusLast Update
0002121OpenFOAM[All Projects] Bugpublic2016-06-19 17:33
ReportersariewAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Versiondev 
Summary0002121: wmake libso error!
DescriptionAllwmake log said '
...
/home/sariew9/OpenFOAM/OpenFOAM-dev/applications/utilities/surface/surfaceLambdaMuSmooth
/usr/bin/ld: cannot find -lconformalVoronoiMesh
/usr/bin/ld: cannot find -lcv2DMesh
/usr/bin/ld: cannot find -lextrude2DMesh
/usr/bin/ld: cannot find -lfoamToVTK
/usr/bin/ld: cannot find -lmetisDecomp
/usr/bin/ld: cannot find -ltabulatedWallFunctions
/usr/bin/ld: cannot find -luserd-foam
collect2: error: ld returned 1 exit status
make[2]: *** [/home/sariew9/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/bin/foamList] Error 1
make[1]: *** [foamList] Error 2
make[1]: *** Waiting for unfinished jobs....
... ."

then I trid to seeking 7 libso before 'Allwmake'.
Although 5 libso already were installed in $FOAM_LIBBIN,
2 libso, libconformalVoronoiMesh.so and libmetisDecomp.so, were missing.

So I tried compiling them, but libconformalVoronoiMesh.so could not be compiled
because 'wmake' did not find the header file - CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h -.
I can not find this header file as well.

What do I need next?
TagsNo tags attached.

Activities

sariew

2016-06-16 04:55

reporter  

makeLIBSO.log.tar.gz (2,177 bytes)

henry

2016-06-16 08:12

manager   ~0006443

I have just pushed a fix for this, let me know if it resolves the problem for you.

sariew

2016-06-17 03:27

reporter   ~0006444

Today, He said
'...
g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=64 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3 -DNoRepository -ftemplate-depth-100 -I/home/sariew9/OpenFOAM/OpenFOAM-dev/src/meshTools/lnInclude -I/home/sariew9/OpenFOAM/OpenFOAM-dev/src/triSurface/lnInclude -IlnInclude -I. -I/home/sariew9/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude -I/home/sariew9/OpenFOAM/OpenFOAM-dev/src/OSspecific/POSIX/lnInclude -fPIC -c surfaceInertia.C -o /home/sariew9/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/applications/utilities/surface/surfaceInertia/surfaceInertia.o
/usr/bin/ld: cannot find -lextrude2DMesh
/usr/bin/ld: cannot find -lfoamToVTK
/usr/bin/ld: cannot find -ltabulatedWallFunctions
/usr/bin/ld: cannot find -luserd-foam
collect2: error: ld returned 1 exit status
make[2]: *** [/home/sariew9/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/bin/foamList] Error 1
make[1]: *** [foamList] Error 2
make: *** [miscellaneous] Error 2
make: *** Waiting for unfinished jobs....
... ."

um... These 4 libso have been installed in $FOAM_LIBBIN.
The messages for libconformalVoronoiMesh.so, libcv2DMesh.so and libmetisDecomp.so
are gone but I haven't done anything. I only understood that some codes were changed in today's patches.

henry

2016-06-17 07:38

manager   ~0006445

Try now.

henry

2016-06-19 17:33

manager   ~0006447

Resolved by commit af3198d76ca6703f9cb98d526f0d98b68283a861

Issue History

Date Modified Username Field Change
2016-06-16 04:55 sariew New Issue
2016-06-16 04:55 sariew File Added: makeLIBSO.log.tar.gz
2016-06-16 08:12 henry Note Added: 0006443
2016-06-17 03:27 sariew Note Added: 0006444
2016-06-17 07:38 henry Note Added: 0006445
2016-06-19 17:33 henry Note Added: 0006447
2016-06-19 17:33 henry Status new => resolved
2016-06-19 17:33 henry Fixed in Version => dev
2016-06-19 17:33 henry Resolution open => fixed
2016-06-19 17:33 henry Assigned To => henry