View Issue Details

IDProjectCategoryView StatusLast Update
0002112OpenFOAMPatchpublic2016-06-10 22:20
ReporterwyldckatAssigned Tohenry 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0002112: Minor proposal relative to updates made to bashrc/cshrc and aliases on the 6 and 7th of June 2016
DescriptionThis report/patch is for the following issues:

 - The cleanup made in the "aliases" files is very welcome, although "foam3rdParty" is something that I use very frequently when handling various OpenFOAM builds.

 - The new self-adjusting installation path is really welcome (I can't believe I never thought of it), but the hard-code to the folder "OpenFOAM" is opposite to the standard defined throughout the environment files. It should use "$WM_PROJECT" for maintaining generalization, at least for user-side internal management.

The attached file "minor_fixes_v1.tar.gz" provides the updated files for recovering "foam3rdParty" and for generalizing the installation path that is defined in "$WM_PROJECT", namely these files:

 - etc/bashrc
 - etc/config.sh/aliases
 - etc/config.sh/unset

 - etc/cshrc
 - etc/config.csh/aliases
 - etc/config.csh/unset

Note: I didn't test the change made to "etc/cshrc", but I expect it should work as intended.
TagsNo tags attached.

Activities

wyldckat

2016-06-08 11:30

updater  

minor_fixes_v1.tar.gz (5,220 bytes)

henry

2016-06-08 11:49

manager   ~0006407

I agree with the "$WM_PROJECT" change and will apply it and also test the change for csh. However, I don't see a good reason to keep the foam3rdParty alias which is commonly used; I want to reduce the environmental clutter OpenFOAM generates. I would recommend that you maintain this alias in your own ~/.OpenFOAM/... configuration files.

henry

2016-06-08 11:53

manager   ~0006408

Resolved by commit 477d40f0a23cabdb9fe0a45923832fe2687d4911

wyldckat

2016-06-10 21:14

updater   ~0006427

Sorry to reopen this, but it's just to report that "wmRefresh" is missing from "etc/config.*/unset" :(


Nonetheless, I'll take the opportunity to comment that "foam3rdParty" will indeed be missed, specially with the recent addition 3rd party source code that had to be made in ThirdParty-dev... but given that the 3rd party source code is only needed when building/installing and rarely compiled during standard usage of OpenFOAM, I can (mostly) understand why it's preferable to keep things clean for standard work environments.

henry

2016-06-10 22:20

manager   ~0006429

Resolved by commit 9cf8bd8313f4368aba7fb84ce622c0845d7c8552

Issue History

Date Modified Username Field Change
2016-06-08 11:30 wyldckat New Issue
2016-06-08 11:30 wyldckat Status new => assigned
2016-06-08 11:30 wyldckat Assigned To => henry
2016-06-08 11:30 wyldckat File Added: minor_fixes_v1.tar.gz
2016-06-08 11:49 henry Note Added: 0006407
2016-06-08 11:53 henry Note Added: 0006408
2016-06-08 11:53 henry Status assigned => resolved
2016-06-08 11:53 henry Fixed in Version => dev
2016-06-08 11:53 henry Resolution open => fixed
2016-06-10 21:14 wyldckat Note Added: 0006427
2016-06-10 21:14 wyldckat Status resolved => feedback
2016-06-10 21:14 wyldckat Resolution fixed => reopened
2016-06-10 22:20 henry Note Added: 0006429
2016-06-10 22:20 henry Status feedback => resolved
2016-06-10 22:20 henry Resolution reopened => fixed