View Issue Details

IDProjectCategoryView StatusLast Update
0002109OpenFOAM[All Projects] Bugpublic2018-10-19 11:38
Reportereagleyc123Assigned Towill 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
PlatformOpenFOAMOSLinux Ubuntu OS VersionUbuntu 15.04
Product Versiondev 
Fixed in Versiondev 
Summary0002109: Surface mesh changes at the interface, the ACMI doesn't work as expected.
DescriptionA sliding interface between two domains is defined using ACMI. As long as the shape of the two domains remain constant but move with a relative velocity to each other, the ACMI works fine. However, when the relative velocity is not obtained from the movement of the entire domain, but by surface mesh changes at the interface, the ACMI doesn't work as expected. Such a situation comes up, when the interface surface mesh is moved/changed as a result of velocityComponentLaplacian-solver. One would expect, that the surface mesh slides along the interface as calculated by the solver. Instead, it sticks at the position where the ACMI is defined. Please feel free to have a look at the attached file for better understanding.
Additional InformationIf needed, it is possible to provide the whole case with the current settings.
TagsNo tags attached.

Relationships

duplicate of 0002057 resolvedhenry ACMI incompatible with velocityComponentLaplacian 

Activities

eagleyc123

2016-06-02 10:29

reporter  

ACMI.tar.gz (221,106 bytes)

will

2018-10-19 11:38

manager   ~0010117

This should now be resolved by commit a0a88d66 in dev. There is no case attached to this report to confirm this. If the problem persists, please open a new report.

Issue History

Date Modified Username Field Change
2016-06-02 10:29 eagleyc123 New Issue
2016-06-02 10:29 eagleyc123 File Added: ACMI.tar.gz
2016-06-02 10:36 henry Relationship added duplicate of 0002057
2018-10-19 11:38 will Assigned To => will
2018-10-19 11:38 will Status new => resolved
2018-10-19 11:38 will Resolution open => duplicate
2018-10-19 11:38 will Fixed in Version => dev
2018-10-19 11:38 will Note Added: 0010117