View Issue Details

IDProjectCategoryView StatusLast Update
0002105OpenFOAMContributionpublic2016-05-31 21:27
Reportera.weberAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Versiondev 
Summary0002105: origId of parcels not unique when breakup model is used
DescriptionBreakup of parcels will cause mutiple identical origIds. When breakup occurs, the daughter parcel will be copied from the motherparcel including the origId information. This will cause for example the postprocessing "particleTracks" to generate wrong trajectories.
Steps To ReproduceAny SprayFoam simulation with breakup models active.
Additional InformationIn SprayParcel.C, add "child->origId() = this->getNewParticleID();" to give every daughter parcel a new unique origId.
TagsNo tags attached.

Activities

a.weber

2016-05-31 13:16

reporter   ~0006343

BTW: have not tested the solution in parallel....

henry

2016-05-31 13:34

manager   ~0006345

Let us know when you have complete testing this change.

dkxls

2016-05-31 18:35

reporter   ~0006349

Last edited: 2016-05-31 18:53

View 2 revisions

Just to mention, this only affects the KHRT and SHF breakup models because these are the only ones that generates new parcels.

Otherwise, I think that this should be fixed as it indeed may cause problems in certain setups (as mentioned for particle tracks, but also when e.g. reconstructing a decomposed case).

henry

2016-05-31 21:27

manager   ~0006350

Resolved in OpenFOAM-dev by commit bb3910ddaf788f44335c1ab7d5e063eb691cea8c

Issue History

Date Modified Username Field Change
2016-05-31 13:14 a.weber New Issue
2016-05-31 13:16 a.weber Note Added: 0006343
2016-05-31 13:34 henry Note Added: 0006345
2016-05-31 18:35 dkxls Note Added: 0006349
2016-05-31 18:53 dkxls Note Edited: 0006349 View Revisions
2016-05-31 21:27 henry Note Added: 0006350
2016-05-31 21:27 henry Status new => resolved
2016-05-31 21:27 henry Fixed in Version => dev
2016-05-31 21:27 henry Resolution open => fixed
2016-05-31 21:27 henry Assigned To => henry